x264 obraz skacze w sony vegas
#1
Witam mam problem z materiałem kodowanym w x264. Odtworzyć mogę (tylko Film i TV z z win10 ma problem i nie otwiera). Problem pojawia się po wczytaniu takiego pliku do Vegasa. Na podglądzie jak również po renderze obraz skacze.

Proszę o jakieś wskazówki co z tym zrobić. 

Dane pliku z mediainfo

Kod:
Ogólne
Pełna ścieżka                           : D:\załadunek\Punkt_Załadunkowy_2_2016_07_05_14_56_38.avi
Format                                  : AVI
Format/Informacja                       : Audio Video Interleave
Rozmiar pliku                           : 1,12 MiB
Czas trwania                            : 9s 625 ms
Rodzaj całkowitej przepływności bitów   : Zmienna
Całkowita przepływność bitów            : 973 kb/s

Wideo
ID                                      : 0
Format                                  : AVC
Format/Informacja                       : Advanced Video Codec
Profil formatu                          : Main@L4.1
Ustawienia formatu, CABAC               : Tak
Ustawienia formatu, poklatkowy          : 2 klatki
Format_Settings_GOP                     : M=1, N=50
ID kodeka                               : H264
Czas trwania                            : 9s 600 ms
Rodzaj przepływności                    : Zmienna
Przepływność bitów                      : 902 kb/s
Przwpływność maksymalna                 : 5.120 b/s
Szerokość                               : 1.920 pikseli
Wysokość                                : 1.080 pikseli
Proporcje obrazu                        : 16:9
Szybkość wyświetlania klatek            : 30,000 kl/s
Oryginalna szybkość wyświetlania klatek : 25,000 kl/s
ColorSpace                              : YUV
ChromaSubsampling/String                : 4:2:0
BitDepth/String                         : 8 bitów
Rodzaj skanu                            : Progresywny
bity/(piksele*ramki)                    : 0.014
Rozmiar strumienia                      : 1,03 MiB (92%)
colour_range                            : Limited
colour_primaries                        : BT.709
transfer_characteristics                : BT.709
matrix_coefficients                     : BT.709

Audio
ID                                      : 1
Format                                  : ADPCM
Profil formatu                          : U-Law
ID kodeka                               : 7
ID kodeka/Wskazówka                     : CCITT
Czas trwania                            : 9s 625 ms
Rodzaj przepływności                    : Stała
Przepływność bitów                      : 64,0 kb/s
Kanały                                  : 1 kanał
Częstotliwość próbkowania               : 8.000 Hz
BitDepth/String                         : 8 bitów
Rozmiar strumienia                      : 75,2 KiB (7%)
Przeplot, czas trwania                  : 125  ms (3,74 klatki wideo)

Kodeki K-Lite Mega Pack
W konfiguracji FFDShow i x264vfw pliki w ogóle nie chcą się odtwarzać a vegas nie wczytuje pliku.
Mogę to nawet konwertować przed pracą, tego dużo nie mam grunt żeby działało.
Odpowiedz
#2
Vegas wczytuje h.264 (AVC) natywnie. Nie potrzebuje dodatkowych kodeków. Problem się zaczyna, jak plik jednak nie jest zakodowany standardowym h.264, tylko modyfikowanych (autorski kodek firm trzecich).
Prawdopodobnie tak jest, lub masz namieszane w kodekach.

Po pierwsze, użyj jakiegoś muxera, (np. TsMuxer), aby wyciągnąć strumienie - i osobno wrzucić do Vegasa (funkcja Demux - powstaną dwa pliki -> osobno obraz, osobno dźwięk. Vegas powinien to przeczytać.
Ewentualnie można przemuxować do M2TS i próbować to wczytać.

Polecam też zrobienie porządku w systemie -> odinstalowanie pakietu kodeków, przeczyszczenie rejestru, aktualizacja windowsa, próba odtworzenia pliku w Windows Media Player (jeśli system nie ma kodeku, powinien automatycznie zassać w aktualizacji).
Później próba wrzucenia do Vegasa.
Odpowiedz
#3
@mateuszszar muxowanie do M2TS pomogło. Plik w tym formacie normalnie otwiera się w Vegasie. Jeśli chodzi o system to jest prawie świerzynka, miesiąc użytkowania.
Odpowiedz
#4
Jak pomogło - to problem rozwiązany. AVI nie jest najlepszym kontenerem dla h264. Jak widać nie tyloo vegas ma z tym problem.
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z XAVC XD - obraz skacze the_criss 1 365 10-30-2015, 23:24
Ostatni post: daruncio1
  Obraz skacze przy kilku ścieżkach, BŁĄD j0hny21 4 1,488 01-24-2014, 14:11
Ostatni post: j0hny21
  Sony Vegas 11 Pro - rozmyty obraz po renderingu Araulen 24 7,247 12-08-2013, 15:56
Ostatni post: efix
  Rander x264, brak synch z audio. 8005macgyver 10 1,475 09-19-2013, 9:49
Ostatni post: 8005macgyver
  x264 Nie wczytuje Sony Vegas eryk172 1 1,050 08-22-2012, 12:42
Ostatni post: mateuszszar
  Sony vegas dzieli obraz (tylko w full HD) tomciodentysta 11 2,718 02-28-2011, 22:58
Ostatni post: efix

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości