Coś crash'uje SV.
#1
Witam. Ostatnio jak co dzień montowałem filmik w SV i nagle bez powodu wywaliło mi crasha. Po ponownym uruchomieniu zauważyłem, że nie widzi połowy klipów, a w dodatku po odczekaniu 1 minuty około znowu następuje crash. Co może być powodem? Reinstalowałem go z 3x i dalej nic.

Log:
Cytat:Sony Vegas Pro 8.0
Version 8.0a (Build 179)
Exception 0xC0000005 (access violation) WRITE:0x2E8A50 IP:0x7C9374E9
In Module 'ntdll.dll' at Address 0x7C900000 + 0x374E9
Thread: VideoCache ID=0x1720 Stack=0x843F000-0x8440000
Registers:
EAX=002e2ea0 CS=001b EIP=7c9374e9 EFLGS=00010216
EBX=1fd69e6c SS=0023 ESP=0843f674 EBP=0843f6a4
ECX=00005228 DS=0023 ESI=1fd69e64 FS=003b
EDX=bfa91a86 ES=0023 EDI=536be420 GS=0000
Bytes at CS:EIP:
7C9374E9: 89 B4 01 88 09 00 00 5E .......^
7C9374F1: B0 01 5B 5F C9 C3 B8 00 ..[_....
Stack Dump:
0843F674: 536BE428 4FF00000 + 37BE428
0843F678: 00000000
0843F67C: 00140000 00140000 + 0
0843F680: 7F681FDB 7F330000 + 351FDB
0843F684: BFA91A87
0843F688: 97AD1FDA
0843F68C: BFA91A86
0843F690: 00000000
0843F694: 00000001
0843F698: F437E8DD
0843F69C: 7C9109BA 7C900000 + 109BA (ntdll.dll)
0843F6A0: 0015F818 00140000 + 1F818
0843F6A4: 0843F768 08340000 + FF768
0843F6A8: 7C936F74 7C900000 + 36F74 (ntdll.dll)
0843F6AC: 00000000
0843F6B0: 50915008 4FF00000 + A15008
> 0843F728: 0101FFA4 00400000 + C1FFA4 (vegas80.exe)
0843F72C: 00008200
0843F730: 00140000 00140000 + 0
0843F734: 4BD20000
0843F738: 0843FFA4 08340000 + FFFA4
> 0843F73C: 7C90E920 7C900000 + E920 (ntdll.dll)
> 0843F75C: 7C90E920 7C900000 + E920 (ntdll.dll)
> 0843F760: 7C910060 7C900000 + 10060 (ntdll.dll)
> 0843F76C: 024A236D 024A0000 + 236D (mfplat.dll)
0843F770: 00140000 00140000 + 0
0843F774: 00000000
0843F778: 536BE428 4FF00000 + 37BE428
0843F77C: 0843F798 08340000 + FF798
> 0843F780: 161A2783 16180000 + 22783 (WMVDECOD.dll)
> 0843F79C: 161A86A7 16180000 + 286A7 (WMVDECOD.dll)
> 0843F7AC: 161973B3 16180000 + 173B3 (WMVDECOD.dll)
> 0843F7BC: 16198A85 16180000 + 18A85 (WMVDECOD.dll)
> 0843F7DC: 16198B2E 16180000 + 18B2E (WMVDECOD.dll)
> 0843F7E8: 1618AA25 16180000 + AA25 (WMVDECOD.dll)
> 0843F7F4: 1618B31D 16180000 + B31D (WMVDECOD.dll)
> 0843F804: 1618D5C9 16180000 + D5C9 (WMVDECOD.dll)
> 0843F814: 151C25FF 15110000 + B25FF (WMVCore.DLL)
> 0843F820: 151C76C1 15110000 + B76C1 (WMVCore.DLL)
> 0843F834: 1517988E 15110000 + 6988E (WMVCore.DLL)
> 0843F848: 151798CB 15110000 + 698CB (WMVCore.DLL)
> 0843F85C: 1517999D 15110000 + 6999D (WMVCore.DLL)
> 0843F878: 15179AF8 15110000 + 69AF8 (WMVCore.DLL)
> 0843F898: 1517E18C 15110000 + 6E18C (WMVCore.DLL)
> 0843F8AC: 151691F0 15110000 + 591F0 (WMVCore.DLL)
> 0843F8D0: 152ABC67 15110000 + 19BC67 (WMVCore.DLL)
> 0843F8F0: 15170819 15110000 + 60819 (WMVCore.DLL)
> 0843F900: 15171913 15110000 + 61913 (WMVCore.DLL)
> 0843F910: 15173253 15110000 + 63253 (WMVCore.DLL)
> 0843F928: 152B1BD7 15110000 + 1A1BD7 (WMVCore.DLL)
> 0843F96C: 15138327 15110000 + 28327 (WMVCore.DLL)
> 0843F984: 1516871C 15110000 + 5871C (WMVCore.DLL)
> 0843F9A0: 1513743E 15110000 + 2743E (WMVCore.DLL)
> 0843F9C0: 15135980 15110000 + 25980 (WMVCore.DLL)
> 0843F9D8: 04237EFB 04230000 + 7EFB (wmfplug3.dll)
0843F9DC: 3C0283F8 3BF20000 + 1083F8
0843F9E0: 023EBF6B 023E0000 + BF6B
0843F9E4: 00000000
0843F9E8: 00000000
> 0843FA00: 04239F07 04230000 + 9F07 (wmfplug3.dll)
0843FA04: 00000001
0843FA08: 00000071
0843FA0C: 00000000
0843FA10: 0843FA6C 08340000 + FFA6C
> 0843FA2C: 006B1E3B 00400000 + 2B1E3B (vegas80.exe)
> 0843FA70: 7C810038 7C800000 + 10038 (kernel32.dll)
> 0843FAA0: 0120A894 01150000 + BA894 (vegas80k.dll)
- - -
0843FFF0: 00000000
0843FFF4: 00598AE0 00400000 + 198AE0 (vegas80.exe)
0843FFF8: 00ADA7FC 00400000 + 6DA7FC (vegas80.exe)
0843FFFC: 00000000

Okienko w SV po crashu wyglada następująco:
[Obrazek: blad.jpg]
Potem się zacina i wyłącza.
Jeżeli pomogłem - DAJ RUPUTA ;}

[Obrazek: fma.jpg]
Odpowiedz
#2
Poszukaj info o 'ntdll.dll' i co inni z nim zrobili.
Odpowiedz
#3
Co masz na myśli?
Odpowiedz
#4
http://www.google.pl/search?q=ntdll.dll+...PL326&sa=2 ot co.
Odpowiedz
#5
O znalazlem nowy błąd. Teraz wyskoczył taki, gdzie pisało, że program nie może znaleść miejsca na "zalokowanie" jakiegoś kodeku. Może to gdzieś w ustawieniach? Po za tym po skopiowaniu tego wszystkiego na nowy projekt wszystko niby dziala, tylko musze Track Motion skopiować.
Odpowiedz
#6
Heh zrób tak: Ctrl+a ctrl+c i w nowym projekcie ctrl+v powinno działać.
Odpowiedz
#7
No tak zrobiłem właśnie i działa, ale miałem na tym projekcie dużo keyów w Motion 3D i mi ich troche żal.

EDIT: Heh, ale mam sposób na to xD Uruchamiam 2 projekty, w jednym puszczam filmik i crashuje go, a drugi już nie wykrywa błędu i go nie crashuje xD Ale musze tak robic za każdym razem i to jest niewygodne.
Odpowiedz
#8
Ehh, dalej crashuje. Czy jest jakaś obawa, że po podmianie biblotek z system32 wystąpi jakiś błąd. Ze strony dll-files.com ściągnąłem właśnie to ntdll.dll.
Odpowiedz
#9
Na 99% błąd jest powiązany z kodekiem wmv. Spróbuj zaktualizować windows media playera. Jak już pisałem wcześniej - Vegas jest średnio przystosowany do obsługi innych formatów niż DV-avi, nieskompresowany i być może mpeg2 (do HDV)
[Obrazek: i15.jpg]
Odpowiedz
#10
No spróbuje, aby pomogło, bo już mnie szlak bierze... Siedzę już 1 tydzień nad projektem a tu taki błąd...

A czy jest możliwe, że wywala te błędy z powodu uszkodzonej pamięci RAM? Jak pisałem wyżej, wyskoczył komunikat, że nie można zalokować kodeka. Pytam sie dlatego, ponieważ ostatnio podkręcałem procka i lekko RAM i może to jest tego powodem.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości