zielony pasek na filmie skonwertowanym pliku video
#1
Witam!

Mam problem z konwersją pliku video, którego wyrenderowałem wczęśniej w Sony Vegas Pro.

Problem polega na tym, że konwertując video (wyrenderowane w Sony Vegas Pro) w programie Media Coder Premium
na wynikowym pliku pojawia sie zielony pasek na górze video. Wiem, że jest to problem programu Media Coder Premium,
ale może spotkaliście z takim przypadkiem. Dodam, że ten pasek jest tylko widoczny na telewizorze, bo na komputerze
go nie widać.

Czy możecie pomóc, które ustawienie przy konwersji może odpowiadać za pojawianie lub zniknięcie takiego paska video?
Czy to błąd oprogramowania Media Coder Premium?

Wiem, że to nie jest problem Sony Vegas Pro, ale może pomożecie.

Pozdrwiam
Odpowiedz
#2
Ja miałem taki pasek po renderowaniu w Vegasie przy wspomaganiu GPU. Spróbuj wyłączyć wspomaganie GPU w MediaCoderze.
Osobiście nie używam tego programu więc więcej ci nic nie powiem.

A tak a propos - po co konwertujesz wyrenderowany film? Nie możesz wyrenderować w innym kodeku zamiast konwertować?
Pomogłem? Daj plusa :)    [Obrazek: plus.png]
Odpowiedz
#3
(09-26-2015, 21:15)sirCreeper napisał(a):  Ja miałem taki pasek po renderowaniu w Vegasie przy wspomaganiu GPU. Spróbuj wyłączyć wspomaganie GPU w MediaCoderze.
Osobiście nie używam tego programu więc więcej ci nic nie powiem.

A tak a propos - po co konwertujesz wyrenderowany film? Nie możesz wyrenderować w innym kodeku zamiast konwertować?

Tak to prawda, konwertuje przy użyciu GPU, ale nie mogę z tego zrezygnować gdyż to pozwala mi uzyskać super czasy konwersji nawet 3 razy szybsze niż trwa film wejściowy i to w jakości 4K i 100 Mbit/s na wejściu i 50 Mbit/s na wyjśćiu. Konwertuje tak, bo konwertuje do kodeka h.265, którego nie wspiera Vegas.
Odpowiedz
#4
Kombinowałem z horizontal deblocking (tj. zaznaczyłem tę opcję) cokolwiek by to oznaczało, ale nie pomogło.
Odpowiedz
#5
Chyba udało mi się znaleźć problem, choć jest to cholernie dziwne, ale tak jest.
Rozdzielczość 4K to 3280 x 2160, szerokość 3280 jest podzielna przez 64 (bo tyle wynosi blok pikseli dla HEVC 4K), natomiast 2160 nie jest podzielne przez 64.
W związku z tym wykonałem zmianę rozmiarów rozdzielczości z 3280 x 2160 na 3280 x 2112 i teraz na telewizorze nie mam zielonych pasków.

Nigdzie nie mogłem znaleźć przykładu dla 4K, były przykłady tylko dla FULL HD i rozmiaru bloku 16, no i z analogii doszedłem do tego, że problem jest w podzielności przez 64.

Może się komuś to przyda, więc piszę.
Odpowiedz
#6
(09-27-2015, 0:33)Kamyk79 napisał(a):  Chyba udało mi się znaleźć problem, choć jest to cholernie dziwne, ale tak jest.
Rozdzielczość 4K to 3280 x 2160, szerokość 3280 jest podzielna przez 64 (bo tyle wynosi blok pikseli dla HEVC 4K), natomiast 2160 nie jest podzielne przez 64.
W związku z tym wykonałem zmianę rozmiarów rozdzielczości z 3280 x 2160 na 3280 x 2112 i teraz na telewizorze nie mam zielonych pasków.

Nigdzie nie mogłem znaleźć przykładu dla 4K, były przykłady tylko dla FULL HD i rozmiaru bloku 16, no i z analogii doszedłem do tego, że problem jest w podzielności przez 64.

Może się komuś to przyda, więc piszę.

Najlepsze jest w tym wszystkim to, że to chyba bug kodeka x265.
Konwertując materiał 4K do kodeka H.264 zielonego pasku nie ma.
Konwertując materiał 4K do kodeka H.265 zielony pasek jest.
Najgorsze jest to, że autor oprogramowania mnie olewa.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości