Pixele po Renderowaniu
#1
Witam,
Mam problem z pojawieniem się pixeli po renderowaniu. Pojawiają się one głównie podczas ruchu postaci w centralnej części ekranu rozmazując niejako ruch. Przeglądałem forum pod tym kontem i znalazłem taki wątek, który niejako jest podobny do mojego problemu link: http://sonyvegas.info/thread-6948.html?h...ht=piksele jednak moje wnioski z tego tematu są takie, że Sony Vegas pro 12 po prostu umieszcza czasem takie artefakty i nie idzie tego zmienić. Niemniej jednak jak macie jakieś inne pomysły to chętnie spróbuję je wykorzystać, ponieważ owe artefakty są bardzo denerwujące... Może jednak się da coś zrobić i paru godzinna praca nie pójdzie na marne...???
Zdjęcia moich ustawień:
Custom Settings:
[Obrazek: Custom_Settings.th.jpg]
Match Media Video Settings:
[Obrazek: Match_Media_Video_Settings.th.jpg]
Properties:
[Obrazek: Properties.th.jpg]
Pozdrawiam
Odpowiedz
#2
Przede wszystkim w oknie customize settings, przy ustawieniach renderingu, wybierz profil "high" a nie "main".

Film źródłowy masz 50kl/s. I tak samo ustaw projekt i tak też renderuj.
Jeśli zmieniasz ilość klatek (np do 30, jak w Twoimprojekcie i renderze), to koniecznie użyj 'disable resample', we wszystkich klipach.

Jeśli problem z pixelozą będzie nadal, daj większy bitrate (10-12mbps).
Odpowiedz
#3
Dzięki za odpowiedź.
Zmiana na profilu z "main" na "high" - okey nie mam z tym problemu, ale co dalej...?
Frame rate w "Project Properties" zmienić na 50tys. (Double PAL)? skoro plik źródłowy mam w 50kl/s. Przepraszam, że pytam, ale ogólnie jestem w tym totalnie zielony.. Co do innych ustawień w projekcie także nie wiem jakie powinny być prawidłowe w odniesieniu do pliku źródłowego :( Czy wtedy wszystko się zmienia czy tylko ilość kl/s zmienić? Dodatkowe 'disable resample' także nie wiem gdzie to wyłączyć... za to wiem jak zmienić bitrate (chociaż coś), ale min. ma być 10mbps a max 12mbps? czy lepiej ustawić wartość pośrednią 11mbps dla obu?
Jak byś miał czas mógłbyś napisać co konkretnie zrobić? :)
Po drugie jest może gdzieś napisane co ZA co konkretnie odpowiada, bo ja to tak trochę w ciemno poustawiałem i zawsze wychodziło w miarę okey... ale teraz pixeloza nie daje żyć :(((
Jeszcze raz dzięki za jakąś odpowiedź :D
Odpowiedz
#4
Piszę z telefonu dlatego tak ogólnie.

Disable resample, znajdziesz na forum, lub w pomocy programu (f1). Tak jak pisałem jest to funkcja którą ustawia się dla każdego klipu (eventu), więc prawy przycisk myszy > properties...

Klatkaż ustaw taki sam jak w plikach wsadowych, wówczas nie będziesz sobie zawracał głowy 'disable resample'.
A najlepiej użyj funkcji 'match media', w oknie ustawień projektu.

Przydałby się jeszcze jakiś screen lub plik choćby na yt, żeby ktoś z nas mógł napisać, w czym problem. Bo wiesz, kodeki mają swoje ułomności. I przy dynamicznym obrazie koder może po prostu nie wyrabiać. Ale bardziej przypuszczam że masz problem z niewłaściwym klatkażem.

Twoje pliki są 59.184. Niestandardowy klatkaż. Pewnie jeszcze zmienny (sprawdź właściwości pliku za pomocą MediaInfo - taki darmowy program).
Jeśli to pliki z telefonu, to dodatkowy problem. Telefony kodują specyficznie.
Odpowiedz
#5
No tak tylko jak sam zauważyłeś klatkaż jest zmienny, ponieważ w każdym oddzielnym filmie jest inny. Przynajmniej tak mi się wydaje. Filmy nagrywałem za pomocą aparatu, który nagrywa niby w HD, więc problem telefonu odchodzi...
W końcu nie wiem czy mam robić to Disable resample czy nie, bo jak to problem z klatkami to może lepiej rozwiązać ten problem...
W sumie, może dlatego, że jestem trochę zielony zwłaszcza jeśli chodzi o renderowanie ( zawsze mam z tym jakiś problem) to nie zrozumiałem za wiele z Twojego ostatniego posta.
Dodaję tylko screena z tego programu, który poleciłeś mi ściągnąć...
[Obrazek: media.th.jpg]

Jak byś mógł napisać trochę bardziej zrozumiale (po polsku hehe), co konkretnie mam zmienić, zrobić lub przerobić to będę bardzo wdzięczny :)
Odpowiedz
#6
Ten klip ma jeszcze inne parametry...
Nie można mieszać różnych systemów do kupy (różnych klatek na sekundę).

Vegas nie ma możliwości zapisu z zmienną szybkością klatek na sekundę. Więc przy takich rozbieżnościach musisz jednak zastosować "disable resample".
Dzięki za screen, ale nie podałeś w właściwej formie (jak w załączonym przeze mnie linku) -> musi być w formie pełnej (na Twoim screenie jest na dole napis: "aby uzyskać więcej informacji musisz wybrać inny widok (Karta, Drzewo...)".
Odpowiedz
#7
Okey "disable resample" zmienione dla wszystkich plików video (pominąłem audio i napisy - nie wiem czy to dobrze). Tak w ogóle co ta opcja daje w skrócie?
Teraz to już nie wiem ile kl/s ustawić i ile mbps powinno być. Poniżej dodaje screeny z MediaInfo z widoku Karta Drzewo, inne też potrzebujesz?
Nie wiem dlaczego ten aparat cyfrowy zmienia te wszystkie parametry... Nie znam się na tym za bardzo, ale wydaje mi się, że może być to przez nasycenie kolorami, bądź pory dnia (dzień/wieczór/noc) Chyba, że t nie robi mu różnicy xD
Drzewo screen 1
[Obrazek: Mediainfo_1_drzewo.th.jpg]
Drzewo screen 2
[Obrazek: Mediainfo_2_drzewo.th.jpg]
Karta
[Obrazek: Mediainfo_klip1_karta.th.jpg]
Jeżeli wszystkie potrzebujesz to nie mam problemu, żeby wszystkie porobić, tylko proszę pomóż mi bo jestem w akcie desperacji.. xD :)
Odpowiedz
#8
Na tym screenie jest 23.976
I tak powinieneś ustawić projekt.
Tylko nie wiem dlaczego na pierwszym screenie kilka postów wyżej miałeś plik z 50kl/s...

Ustaw projekt na 23.976 a w klipach z innym klatkażem ustaw 'disable resample'.


Ile kbps przy renderingu? Zależy gdzie ma trafić Twoje video. Bo jak na yt, to wystarczy 8-10mbps. A jeśli chcesz mieć lepszą jakość, bo będziesz puszczał z pendrive'a, to możesz dać więcej - 12-15mbps.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości