Artefakty i haczenie po renderingu do Pal DVD Video Stream
#1
No i nie byłoby normalnie, gdyby mi się normalnie zrenderowało. Po każdej próbie, zawsze w innym miejscu, pojawia mi się na ułamek sekundy coś takiego:

[Obrazek: 20141216141876983781766.jpg]

ewentualnie:
- czarne migotanie klatek
- chwilowy, wręcz ułamkosekundowy zatrzym obrazu (opuszczenie 2-3 klatek).
Potem film odtwarza się dalej, jak gdyby nigdy nic.

Nie widzę żadnego związku między fragmentami, w których się to pojawia. Raz wyskoczyło podczas natłoku ścieżek, drugi raz na płynnym przejściu, ale trzeci w jednym z najlżejszych momentów filmu.

Renderuję spod Win7 opatrzonego kartą nVidia GeForce 525M i procesorem i7-2670QM, do standardowego PAL DVD, ze wszystkimi ustawieniami według sprawdzonego wielokrotnie tutorialu efixa. Jedyne, co musiałem zmienić, to zaznaczyć progressive scan. No i próbowałem już wszystkich kombinacji bitrate'u: Variable, Constant i Two-Pass.

To jest pierwszy film, z którym mam tego rodzaju problem. Może to kwestia nowych sterowników do karty (344.11), ale wydaje mi się absurdalne, żeby nie mogły obsłużyć zwykłego DVD.

Jakieś przemyślenia? :)
Odpowiedz
#2
Być może już pisałeś w jednym z poprzednich postów, ale prosiłbym abyś przypomniał:
- jakiego masz windowsa 7 (bitowość 32 czy 64 bit)
- jakiego masz Vegasa
no i inne parametry komputera, m.in pojemność RAM.

Na pewno pierwszą rzeczą którą bym zrobił na Twoim miejscu, to spróbował zwolnić jak najwięcej pamięci przed renderem (pozamykać wszystkie nie związane z renderingiem aplikacje nawet te chodzące w tle w tym antywirus i na wszelki wypadek odciąć kompowi na ten czas dostęp do internetu)
Jeśli masz 64 bitowy windows, Vegasa conajmniej 12 i więcej niż 4Gb RAM-u a SV nadal ma problemy, to spróbuj jeszcze wyłączyć akcelerację graficzną (restart programu wymagany).
[Obrazek: i15.jpg]
Odpowiedz
#3
Win7 64-bit

Vegas Pro 13
8 GB RAM DDR3 SO-DIMM (laptopowa)

zwolnić jak najwięcej pamięci przed renderem (pozamykać wszystkie nie związane z renderingiem aplikacje nawet te chodzące w tle w tym antywirus i na wszelki wypadek odciąć kompowi na ten czas dostęp do internetu)
Dobra, ostatnim razem net był odcięty, a Dynamic RAM Preview obniżony, ale antywirus nadal chodził. OK, wyłączę go.

Poprzednio wyłączyłem nawet wszystko w domu poza laptopem, żeby dysk nie miał niedoboru prądu - ma to sens?

spróbuj jeszcze wyłączyć akcelerację graficzną

Chodzi ci o GPU, tak? Kiedyś sprawiała problem, później przestała, a obecny projekt już próbowałem na włączonej i wyłączonej. OK, próbuję raz jeszcze bez. Za parę godzin będę wiedział.
Odpowiedz
#4
wersję Vegasa należy podawać wraz z numerem build (najnowszy to 428)
Odpowiedz
#5
W sumie racja. Przepraszam, jeśli gdzieś to jest napisane, a nie zauważyłem. Build jest 290.

W międzyczasie zapuściłem rendering w ustawieniach efixowych + two-pass, bez GPU. Bitrate: Max 9500000, Avg 8500000, Min 7500000. Dla pewności poza antywirusem zabiłem też explorera. Render szedł OK mniej więcej do połowy, potem zatrzymał się ale bez raportu o błędzie, a licznik nadal nabijał time remaining i elapsed. Przespałem się parę godzin i pasek postępu stał dokładnie w tym samym miejscu, a liczniki nadal liczyły. Jakby zawieszenie bez zawieszenia.

Zrestartowałem Vegasa i wyłączyłem two-pass. Jedziemy raz jeszcze...
Odpowiedz
#6
Nadal mam artefakty, ale spróbowałem kilku różnych odtwarzaczy i wyniki są różne:
- Windows Media Player pokazuje rzędy kwadratów migające przez ułamek sekundy
- w Best Player przy użyciu EVR (Vista) pokazuje takie same kwadraty, ale przy przejściu do VMR-9 (DirectX) obraz tylko nieznacznie faluje w miejscu owych kwadratów
- Sony Vegas odtwarza film bez błędu.

Wczoraj nagrałem film z grupowej Wigilii i WMP odtwarza go z kwadratami, natomiast w kopii przesłanej na YouTube nie ma błędu.

To mi daje do myślenia, że klip może wcale nie być uszkodzony, a problem ma naturę sprzętową (nie wiem jaką). Spróbuję nagrać płytę, a potem obejrzeć ją na odtwarzaczu DVD i zobaczę, co wyjdzie.
Odpowiedz
#7
(12-19-2014, 18:29)Skrzypiec napisał(a):  To mi daje do myślenia, że klip może wcale nie być uszkodzony, a problem ma naturę sprzętową (nie wiem jaką). Spróbuję nagrać płytę, a potem obejrzeć ją na odtwarzaczu DVD i zobaczę, co wyjdzie.

Może to być albo problem z sterownikiem karty graficznej albo z samą kartą graficzną. Nowe karty mogą posiadać sprzętową dekompresję obrazu a ta może być lekko niekompatybilna z tym co wypluje kodek w SV. Dobrze, że jest jakiś przełom w sprawie :)
[Obrazek: i15.jpg]
Odpowiedz
#8
Z tego, co udało mi się ustalić:
1) część objawów mogła być sprzętowa
2) część była definitywnie spowodowana nieprawidłowym renderingiem.

Ad.1: Niestety zabrakło mi czasu, żeby wrócić do starych sterowników i renderować pod nimi dla porównania. Na razie wystarczyło mi wiedzieć, że "zacinający się film" to złudzenie.

Ad.2: Tu zrobiłem co następuje:
- wywaliłem wszystkie zbędne programy i dane, co umożliwiło przerzucenie cały projektu na dysk systemowy
- powyłączałem wszystkie procesy, a nawet usługi, schodząc do 928 MB-ów użytego RAM-u, co jest moim osobistym rekordem pod Win7
- wyciąłem szczególnie wrażliwy fragment filmu, w którym kolory zmieniały się radykalnie na czas jednej klatki, czego program z jakiegoś powodu nie mógł ścierpieć (w tym miejscu materiał skakał po dwóch osobnych renderach).

Kombinacja tego wszystkiego pozwoliła mi z na pozór wadliwych surowców wypalić płytę, która działa bez błędu. Dziękuję za pomoc - spróbuję z tymi sterownikami przy następnym filmie (który notabene jest ostatnim, który muszę zrobić, więc trochę poniewczasie, ale co tam - przyczynę trzeba znać).

W ogóle niesamowita sprawa widzieć, jak monitor zasobów skacze do 100% procesora przy renderingu do MP4, natomiast nie używa nawet 60% przy zgrywaniu do AVI (w obu przypadkach źródłem było AVCHD, więc dosyć ciężki towar).

Zauważyłem też, że użycie RAM-u wzrasta wraz z postępem renderingu. Na początku miałem 2.61, na końcu 3.21, jakby program cały czas przejmował się klatkami, które już przerobił zamiast myśleć o tych, którymi zajmuje się teraz. Problem z uwalnianiem RAM-u?
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Spowolnienie filmu a fps materiału wyjściowego + artefakty na materiale wyjściowym kr1st0 1 439 04-03-2015, 20:01
Ostatni post: koks
  jak otworzyć avi video stream: JPG Danieljuss 34 4,822 06-24-2013, 9:37
Ostatni post: Danieljuss
  DVD Architect PAL Widescreen stream renderuje do 4:3 zamiast 16:9 kseba 14 2,878 04-28-2013, 8:59
Ostatni post: daruncio1
  Dziwne artefakty mrWodoo 2 898 09-16-2012, 0:50
Ostatni post: mrWodoo
  Niechciane artefakty - Jaki kodek wybrać do renderowania w moim przypadku adashko 3 2,547 05-05-2012, 23:51
Ostatni post: adashko

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości