Vegas nie używa gpu do renderowania.
#1
Witam serdecznie!
Mam kartę graficzną z obsługą OpenCL ( starawy radek 6850 ) jednak mimo ustawienia w vegasie by karta wspomogła render tylko procesor jest obciążony, niezależnie czy ustawie MainConcept ( ustawiam OpenCL ) czy Sony AVC/MVC ( renderuj za pomocą gpu o ile jest dostępny ) to i tak w MSI Afterburner użycie gpu stoi na 0% za to procesor hula na 100%. Ma ktoś może sugestię dlaczego tak się dzieje lub jak to naprawić?


Z góry dziękuje za pomoc i pozdrawiam!
Odpowiedz
#2
(11-17-2014, 20:14)Qpoland napisał(a):  Witam serdecznie!
Mam kartę graficzną z obsługą OpenCL ( starawy radek 6850 ) jednak mimo ustawienia w vegasie by karta wspomogła render tylko procesor jest obciążony, niezależnie czy ustawie MainConcept ( ustawiam OpenCL ) czy Sony AVC/MVC ( renderuj za pomocą gpu o ile jest dostępny ) to i tak w MSI Afterburner użycie gpu stoi na 0% za to procesor hula na 100%. Ma ktoś może sugestię dlaczego tak się dzieje lub jak to naprawić?


Z góry dziękuje za pomoc i pozdrawiam!

U mnie na takiej karcie  wspomaganie działa bez problemu.
Jakiego używasz Vegasa?
Odpowiedz
#3
Mam vegasa pro 13 oraz Movie Studio Platinum 12 ( ten drugi to orginał pierwszy zainstalowany tylko by sprawdzić czy wspomaganie na nim działa ), na obu tak samo.
Odpowiedz
#4
(11-18-2014, 18:41)Qpoland napisał(a):  Mam vegasa pro 13 oraz Movie Studio Platinum 12 ( ten drugi to orginał pierwszy zainstalowany tylko by sprawdzić czy wspomaganie na nim działa ), na obu tak samo.

Ja również mam  Movie Studio Platinum 12 i tam działa ,a może sterowniki nie aktualne?
Odpowiedz
#5
Nie, najnowsze ze strony AMD.
Odpowiedz
#6
Witam, czego to może być wina? Kiedyś ten sam vegas na tym samym procesorze montował film w tym samym formacie z kamery do tego samego formatu avchd 1.5 godzinny film w około 2 godziny. Teraz widać to po klatkach, że robi to dłużej. Film trwa 2.5 godziny a montowanie skończyło po 7 godzinach. Wcześniej non stop procesor pracował na 100%, teraz waha się między 65-70% i nie ma 100 procent, chyba że przy uruchamianiu. Wina jakichś kodeków, czy czego?
Odpowiedz
#7
ja mam podobnie. Mam nowego lapka z Nvidią GTX850M. Wczoraj zacząłem próbować obrabiać film z vhs.
Zdziwiło mnie jednak to że w ustawieniach Vegasa GPU acceleration of video processing czy mam ustawione na OF czy na kartę HD Graphics 4600 czy też Nvidia GTX 850M, nie widzę różnicy w wydajności procesora.
Zwiększyłem ilość Ram w ustawieniach dynamic RAM z 200 do 9000 MB ( na kompie mam 16GB). Procentowo procesor praktycznie porusza się w tych samych wielkościach. Otworzyłem panel sterowania Nvidii i tam w zarządzaniu 3d dodałem program Vegas. Niestety to także nie zmieniło wielkości użycia procesora.

Jest jednak różnica pomiędzy ustawieniami ramu 200 a 9000 MB.
Przy 200 MB użycie procesora jest wielkości 90-95% a pamięci fizycznej 25%.
Przy 9000 MB użycie procesora wielkości 75-80% a pamięci fizycznej 60-65%.
Wynika z tego że zwiększona ilość RAMU wspomogła procesor. Dlaczego jednak GPU karty go nie wspomaga.

Wypróbowałem rendering HD na innym klipiei tak jak wyżej nie ma praktycznie różnicy w użyciu procesora. Użycie jest na poziomie 57-70% czyli mniejsze niż przy  klipie z vhs ale jest takie samo dla wszystkich trzech ustawień GPU. Nawet mógłbym się pokusić o stwierdzenie że przy ustawieniach acceleratora GPU na OFF jakby częściej jest na poziomie poniżej 60%.

To chyba nie jest normalne , gdyż o ile dobrze główkuję to właśnie GPU powinno wspierać procek a jednak tego nie robi.
Czy czegoś jeszcze nie ustawiłem czy też Vegas nie wspiera niektórych renderów z ramienia GPU.
Odpowiedz
#8
Raczej zwiększona ilość ramu ODCIĄŻYŁA procesor (teraz zamiast działać na powierzchni 200MB, może operować większą ilością miejsca w pamięci - stąd mniejsze obciążenie -> CPU nie musi ciągle zwalniać i pamięci RAM.

Jeśli chodzi o wsparcie GPU w programie, to jeśli tylko odtwarzasz, to różnica będzie niewielka (dla AVC może trochę większa).
Nałóż kilka filtrów, jakieś przejścia - powinieneś zobaczyć różnicę dla GPU off oraz GPU on.
Odpowiedz
#9
Czyli krok ze zwiększeniem Ramu jest dobrym krokiem. Użycie CPU sprawdzałem podczas redneru ale rzeczywiście na surowym klipie bez żadnych dodatków. Mimo to powinna być chyba różnica przy włączonym i wyłączonym GPU. Potem sprawdzę z dodatkami i zobaczymy.
Odpowiedz
#10
Tak. Ram można powiększyć, ale też bez przesady. Najlepiej znaleźć swój 'złoty środek'.

Jeśli chodzi o wspomaganie GPU, to jak tylko odtwarzasz, obraz nie jest przetwarzany, więc nie ma co liczyć (pomijaj kwestię dekompresji). Zastosuj filtry, to zobaczysz, czy Twoja karta potrafi odciążać komputer, czy nie (bo to też nie działa dobrze w każdej karcie).
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości