m2ts po renderingu - problem z płynnością
#1
Witam.
Sprawa następująca: kamera Sony SR12 *.m2ts 16mbps (FH) 1920x1080 AC3 5.1 obrabiane w Sony Vegas 9b Pro Trial. Maszyna C2Q 9550, 4GB RAM, Vista 64. Rendering do *.m2ts 1920x1080 16Mbps AC3 5.1 - domyślnie ten sam rodzaj pliku co wejściowy tylko obrobiony (przejścia, muzyka, teksty itp..). Problem jest taki, że czyste pliki z kamery są odtwarzane zarówno w komputerze jak i w odtwarzaczu sieciowym – Xtreamer bez najmniejszego problemu – jedynie krótkie przerwy pomiędzy kolejnymi plikami. Natomiast po obróbce pliki nie chcą płynnie odtwarzać się tzn początek – kilka-kilkanaście sekund jest prawidłowe po czym następuje rwanie troszkę lepiej w kompie niż w odtwarzaczu. Jeszcze gorzej jest przy przewijaniu takiego pliku w podglądzie – słychać tylko dźwięk a nie ma obrazu, który na kompie pojawia się po kilku sekundach (zsynchronizowany z dźwiękiem). Czy problem leży w jakiś ustawieniach renderingu ?? Może jakieś klatki kluczowe albo coś. Nadmienię, że kodowanie do WMV HD nie powoduje podobnych problemów z plikami wynikowymi, jednak wolałbym renderować do m2ts z różnych względów np. późniejsza możliwość bezpośredniego odtwarzania w BD oraz ze względu na dźwięk 5.1 którego nie odtwarza mi Xtreamer w przypadku kodeka WMV HD (sam kodek WMV HD jest bardzo dobry jakościowo). Pozdrawiam i proszę o wskazówki.
#2
Próbowałeś zmniejszyć 16Mbps do np. 10? Zawsze pozostaje opcja zapisania do innego formatu, ale widzę, że to nie wchodzi w grę.
Nie udzielam odpowiedzi na PW.
#3
Ciekawa sprawa - wpisując "z palca" ograniczenia bitrate nie udało mi się otrzymać żądanej wartości, standardowo - 16Mbps wychodzi 14,1Mbps przy wpisaniu 20Mbps jest bez zmian, 10Mbps wychodzi coś koło 13Mbps za to wpisując 4Mbps otrzymałem plik 10,1Mbps. Niestety zmniejszenie nie poprawiło znacznie płynności - natomiast pogorszyło jakość. Wydaje mi się, że problem jest jednak z kodekiem jakiego używa vegas. Ja chciałbym otrzymać po renderingu pliki o dokładnie tych samych parametrach co wyjściowy z kamery (wg mediainfo 16,1 Mbps). Niestety na razie się to nie udało. Ciekawe, że testując różne wersje vegasa - pod kątem AVCHD wersja Vegas 9.0b/c (nie PRO) nie potrafiła kodować do m2ts z moim czterordzeniowym procesorem Q9550 - zawieszał się program. Na lapku z C2D "szło" bez problemu choć czas obróbki niemiłosiernie długi i efekt zbliżony do powyższego. Może istnieją jakieś zewnętrzne kodeki do vegasa, które działają poprawnie? Przy okazji wczoraj potestowałem również kodowanie do .avc. Konieczność późniejszego muksowania dzwięku jest zniechęcająca ale efekt końcowy był bardziej niż zadowalający - wielkość pliku zbliżona do .m2ts (dla btr 10Mbps) jakość bdb i dzwięk 5.1.
#4
Problem rozwiązany. Tak jak sygnalizowałem w ostatnio - kodowanie bezpośrednio do .m2ts "nie wychodzi". Natomiast wybór kodeka .avc (sony avc, 1920x1080 BR 16Mbps) produkuje idealny obraz. Potem już tylko dźwięk AC3, plus ewentualnie drugi AC3 np z podkładem muzycznym. Całość muksowana - darmowy TSMuxer i po chwilce mamy piękny kontenerek .m2ts z dzwiękiem AC3 o parametrach prawie takich jak pliki wejściowe - praktycznie nie do rozróżnienia. I o to chodziło. Na razie materiał zbieram na dyskach, ale jak ceny BR spadną do poziomu akceptowalnego (5-7 PLN za płytkę 25GB) to wszystko będzie tam archiwizowane. Pozdrawiam.



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  m2ts - problem z odtwarzaniem Kamyk79 4 9,739 02-21-2010, 19:37
Ostatni post: Kamyk79
  Problem z renderowaniem .MTS do .m2ts Fjord Service 8 4,137 02-19-2010, 23:19
Ostatni post: efix

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości