rednerowanie w vegasie i architekcie do blu-ray
#1
Witam wszystkich.
Mam problem z zakończeniem projektu w dvd architekt i postaram się opisać moje działania z programem Sony od początku. Może ktoś wychwyci jakiś mój błąd i będę wreszcie mógł dokończyć to z czym walczę od kilku dni.
Posiadam nikon d7100 i mam nagrane filmy w rozdzielczości 1920x1080 30p. Po przeczytaniu wieli postów na forum, doszedłem do wniosku że lepsze będzie nagrywanie z 25 klatkami na sekundę. Tak czy inaczej posiadane filmy chcę wypalić na blu ray i tu zaczynam swoją przygodę z soniakiem. Po wielogodzinnych naukach z postów i posiadanych lekcji wideo robię to następująco.
W SV properties ustawiam na custom 1920x1080 29,970 fps. Frame rate na 29,970 NTSC.
Otwieram klip filmu i dokonuje renderingu wybierając ustaienia rendera MainConcept AVC/ACC > Blu-ray 1920x1080 60i > frame rate 29,970 ( oczywiście jak klip będzie nakgrany z 25 klatkami to wybiorę Blu-ray 1920x1080 25p). Na początku nie mogłem zrozumieć dlaczego renderuje mi ię tylko video ale w postach wyczytałem że na blu-ray trzeba osobno wyrenderować video i audio. Więc po wyrenderowaniu video wybieram rendering Dolby Digital AC-3 studio i renderuję audio.Jednak okazało się że po wyrenderowaniu audio w stereo dvd nie mogę potem upuścić tego audio na ścieżkę audio w architekcie, natomiast po wyrenderowaniu w stereo dvd, AGC on mogę opuścić render na ścieżkę audio( nie za bardzo wiem dlaczego tak się dzieje).
Wynik renderowanie. Klip nabrał jakby kolorów jednak delikatnie się przycina nie jest tak płynny jak w oryginale ( nie wiem dlaczego). Spróbowałem też wyrenderować klip na blu-ray 25 klatek mając nadzieję że program sam obrobi nadmiar klatek jak trzeba ale niestety wynik jest słaby- film przy ruchach aparatu rozmazuje się.
Następnie klip przeniosłem do dvd architekt i bez ścieżki dźwiękowej próbowałem go wypalić na twardzielu. W zakładce projekt properties zmieniłem dvd na blu-ray a video format z mpeg-2 na avc. W trakcie pokonywania kolejnych otwierających się kart pokazuje mi się komunikat no messaages to display. Następnie dokonuję się rendering który każdorazowo dochodzi do 66 procent i zatrzymuje się z komunikatem: an error occurred while preparing compilation > File name: STREAM/00001.m2ts
Status: TSWrapper.dll::CTSWrapper::ProcThreadMain::This program has a bug. - m_ptsOfNextGOP is empty.
Nie mam pojęcia jak to przeskoczyć, już mi ręce opadają. Więc proszę o pomoc w tej pierwszej sprawie.
Druga dotyczy walki ze ścieżką video i audio.Nie wiem czy dobrze robię ale po załadowaniu j/w video, przeciągam na ścieżkę audio zrenderowane w vegasie audio. Puszczając film na podglądzie film zaczyna się przycinać ( nie wiem czy tak powinno być i dlaczego tak jest). Potem idę w kierunku renderowania i otrzymuję komunikat :the audio on track 1 of "Untitled.avc 30blur" will be recompressed. Następnie dokonuję renderingu i dochodzę ponownie do 66 procent po czym otrzymuję komunikat : an error occurred while preparing compilation > File name: STREAM/00001.m2ts
Status: TSWrapper.dll::CTSWrapper::ProcThreadMain::This program has a bug. - m_ptsOfNextGOP is empty.

Proszę was o pomoc w obydwóch problemach.
Odpowiedz
#2
dodam jeszcze że ten sam klip renderowany w vegasie w mpeg2 30p chodzi bez zarzutu , płynnie , natomiast w mainconcept avc i sony avc, przy różnych ustawieniach zawsze się przycina ale za to klip jest o wiele ładniejszy, bardziej nasycony w kolory, światła i cienie. Jest to bardzo widoczne. Film dostaje wizualnie jakby parametrów filmowych z kina. W architekcie nie mam problemów z renderowaniem klipu w MPEG2 ale kiedy podłącze audio to także nie ma problemu z renderem. Z tego wynika że problem tkwi w ustawieniach renderu avc ale nie wiem gdzie czy na poziomie vegasa czy architekta albo tu i tu. Proszę ponownie o pomoc
( postaram się nagrać film w 25p i zobaczę wtedy jak się zachowa rendering avc)

Zrobiłem właśnie klip nagrany w fullhd w 25fps. Obrabiałem go w AVC Mainconcept. No i niestety przy renderingu w architekcie 1920x1080 25p dostałem ponownie bana( w tym samym miejscu jak przy obrabianiu klipu 30p). Dodam że po vegasie ten klip tj 25p z kolei przyśpieszał. w oryginale trwał 15 sekund a po renderingu 7 zekund. o co tu chodzi?
Odpowiedz
#3
Czy możesz gdzieś podesłać kawałek klipu z którego korzystasz w Vegasie ?
Odpowiedz
#4
no niestety nie wychodzi mi to kiedy wsadzam w you tube to otrzymuje komunikat że nie obsługują takiego formatu
Odpowiedz
#5
wyślij np tu http://www.sendspace.pl/
Odpowiedz
#6
No więc po kolejnych kilku godzinach prób doszedłem do następujących wniosków:
1. napewno miałem problem z dwoma odtwarzaczami plików. Doszedłem do wniosku że były w jakiś sposób walnięte. Kiedy je wyrzuciłem i odtwarzałem np. media player classic nie miałem problemów z zacinaniem się klipów.
2. przed chwilą renderowałem klip nagrany w 30p w różnych ustawieniach w vegasie tj. klip 60i, 25p smart resample i 25p smart disable. w vegasie zrenderowałem filmy bez problemu ale już w architekcie przeszedł tylko klip 60i. 25p resample i disable kończyły się errorem do dojściu do 66%.
3. podobnie jest z klipem nagranym w 25p. kiedy chcę go renderować w formacie 1920x1080 25p nie ma takich parametrów w properties. jest 25i, 29,976i, 24p, 23,976p. i jak bym nie ustawił to rendering kończy się na 66 procentach.

na różnych forach czytałem posty osób stojących przed tym samym problemem i nie znalazłem odpowiedzi. Gdzieś wyczytałem aby materiał 25p zrenderować w vegasie do 50i a potem w architekcie do 25i. Niestety i tutaj była kicha error przy 66 procentach.
Proszę o dokładne wskazówki jak renderować a vegasie a potem w architekcie materiał nagrany w 30p i 25p.
Odpowiedz
#7
Wystarczy, że odpowiednio wyrenderujesz z Vegasa i Architect niczego nie będzie musiał przeliczać. Masz w Vegasie odpowiednie presety do renderowania do blureya.
Odpowiedz
#8
(11-24-2013, 21:34)nikonel napisał(a):  (...) na różnych forach czytałem posty osób stojących przed tym samym problemem i nie znalazłem odpowiedzi. Gdzieś wyczytałem aby materiał 25p zrenderować w vegasie do 50i a potem w architekcie do 25i. Niestety i tutaj była kicha error przy 66 procentach.(...)

I tutaj przydaje się znajomość podstaw. W tym wypadku (można nawet przeczytać w Wikipedii) - opis standardu DVD oraz BluRay.
Nie ma czegoś takiego, jak 25i - bo to by było dwadzieścia pięć półobrazów, które stworzyłyby 12.5 klatki na sekundę. (chociaż w błąd może wprowadzać samo sony, które używa takiego nazewnictwa w różnych miejscach).

Wracając do samego problemu - BluRay w standardzie PAL obsługuje TYLKO I WYŁĄCZNIE 50i!
Jak masz materiał 50i - zostawiasz 50i.
Jeśli masz 25p - to albo program przeliczy na 50i, albo sam to wcześniej zrób (polecam). Takiego pliku DVD_Architekt nie będzie musiał ruszać (o ile pozostałe parametry będą zgodne z standardem BD, oraz projekt w DVD_Arch będzie poprawnie ustawiony - w PAL a nie w NTSC...)
Odpowiedz
#9
Także byłem zdziwiony w architekcie tym renderem do 25i, bo wiem że coś takiego nie istnieje, jednak w architekcie jest. Zrobiłem w vegasie film nagrany w 25p i zrenderowałem go do 501 a w architekcie do 25i. No i dzisiaj w przeciwieństwie z dniem wczorajszym udało się.
Niby wszystko już wiem ale jednak nasuwają się chyba końcowe pytania.
-Ta nazwa w architekcie 25i to tak naprawdę 50i ( troszkę to bezsensu)
-Materiał nagrany w 25p obrabiam w vagasie do 50i a w architekcie do 25i
-materiał nagrany w 30p obrabiam w 60i
-jakie dokładnie formaty obsługuje blu-rey 1920x1080 bo gdzieś wyczytałem że tylko 50i, 24/25p. co z 60i, 30p
-po co zatem w aparatach są możliwości nagrywania w 24p, 25p, 30p skoro i tak wszystko trzeba renderować do formatu i
-i dlaczego w takim razie w vegasie są a w architekcie nie ma, formaty renderu 25p
Odpowiedz
#10
(11-25-2013, 9:16)nikonel napisał(a):  -Ta nazwa w architekcie 25i to tak naprawdę 50i ( troszkę to bezsensu)
Możesz pokazać, gdzie w DVD_Arch jest 25i?

(11-25-2013, 9:16)nikonel napisał(a):  -Materiał nagrany w 25p obrabiam w vagasie do 50i a w architekcie do 25i
Możemy używać ogólnie przyjętego nazewnictwa? Skoro DVD_Architekt przyjął 50i bez przerabiania, to znaczy że końcowo zostaje 50i a nie 25i (pokaż screen, gdzie jest ta nazwa 25i, ewentualnie której wersji DVD_Arch używasz)

(11-25-2013, 9:16)nikonel napisał(a):  -materiał nagrany w 30p obrabiam w 60i
NIE.

(11-25-2013, 9:16)nikonel napisał(a):  -jakie dokładnie formaty obsługuje blu-rey 1920x1080 bo gdzieś wyczytałem że tylko 50i, 24/25p. co z 60i, 30p
Gdzie wyczytałeś? Źródło proszę. Dlaczego nie basujesz na sprawdzonych źródłach (nawet wikipedia). Standard BluRay jest dokładnie opisany. Gdybyś wcześniej się zapoznał z tą wiedzą, nie musiałbyś zakładać tego tematu - nie byłoby problemu. Jakoś inni robią BluRay i nie pytają o takie podstawowe rzeczy.
Jakbyś był leniem i nie chciało Ci się zaglądać do źródła, sprawdziłbyś chociaż w DVD_Arch. - jakie są szablony w ustawieniach projektu - bo to świadczy o standardzie, który obsługuje ten program - byłoby wszystko jasne.
Przy odrobinie wysiłku można zaglądnąć również do pomocy programu [F1] - gdzie też jest to opisane.

(11-25-2013, 9:16)nikonel napisał(a):  -po co zatem w aparatach są możliwości nagrywania w 24p, 25p, 30p skoro i tak wszystko trzeba renderować do formatu i
-i dlaczego w takim razie w vegasie są a w architekcie nie ma, formaty renderu 25p
A po co w aparatach rozdzielczości powyżej 8Mpix, skoro zwykłe ekrany HD są w stanie wyświetlić 2Mpix, a dopiero w standardzie 4K masz 8Mpix?
Nie każdy materiał z kamery trafia na BluRay. Można przecież zgrywać film do pliku (nośnikiem może być choćby PenDrive - chyba wszystkie nowe urządzenia obsługują ten nośnik)... Wiadomo - w świecie filmowym jeszcze długo pozostanie DVD i Bluray, ale patrząc choćby tu na forum - 90% robi filmiki na YT lub korzysta z odtwarzaczów USB/HDD.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości