Czarny ekran renderowanego avi
#1
Witam

Zmontowałem film zrobiony z 2 kamer ergo 2 plików o różnych formatach.
I tak jak mpeg renderuje się ładnie tak avi jest czarny.

Efekty nałożone na niego działają.
W poglądzie podczas renderowania widać już że coś jest nie tak.

Renderuje do MPEG2

Spróbuję zrenderować w innym formacie ale...
Może wy macie jakiś pomysł co przegapiłem?
Odpowiedz
#2
Do renderowania AVI jakiego kodeka używasz? Może z tym jest problem.
Nie udzielam odpowiedzi na PW.
Odpowiedz
#3
http://screencast.com/t/YThjYThlY

Nagrałem sceencast - może on coś pomoże

W nim chciałem pokazać że wideo działa a po zrenderowaniu już nie.
Jak widać film nie wyświetla się na screencaście - może to ma coś wspólnego z tym...
@tomislater

Ja renderuje do formatu mpeg2 a nie do avi

To z plikiem źródłowym jest problem. A on jest nagrywany przez kamerkę easypix

nie wiem jak sprawdzić kodeki
Odpowiedz
#4
Ehe, masz ten kodek? Jak nie ściągnij i zainstaluj, bo ponoć te kamery go wykorzystują.
Nie udzielam odpowiedzi na PW.
Odpowiedz
#5
Zainstalowanie kodeka to po prostu kliknięcie w plik exe tak?
Ściągnąłem plik, kliknąłem, potwierdziłem i tyle go widziałem. Nie wiem gdzie sprawdzić czy na pewno mam tego kodeka.

W każdym bądź razie po takiej opecji nic się nie zmieniło.
Garść innych symptomów które może pomogą ustalić co jest nie tak:
- wrzucając ten clip na obszarze roboczym pojawia się tylko video! - ścieżka audio się nie wgrywa
- efekty nałożonę na ścieżkę z tym avi się renderują - tylko obraz nie

Ja mogę plik źródłowy przekonwertować na inny format ale jest to rozwiązanie trochę do okoła
Czy jest możliwość zapisania gdzieś sposoby pocięcia jednego materiały i wrzucenie tego na drugi materiał? Tak abym nie musiał tego synchronizować z obrazem z drugiej kamery i ciąć na nowo?
W odmętach dziwacznych programów zainstalowanych na moim kompie znalazłem to:
http://screencast.com/t/MmM3NTMzOG
I sprawdziłem tym ten plik - może to pomoże.
Odpowiedz
#6
Zrób 2 testy:

1 - nowy projekt, wstaw z media generator np szachownicę i wyrenderuj plik mpeg dokładnie o takich samych parametrach jakie ustawiłeś w projekcie w którym masz czarny obraz

2 - jeśli wynik w p1 był prawidłowy (jest obraz) wyrenderuj swój problematyczny projekt w nieskompresowanym AVI
[Obrazek: i15.jpg]
Odpowiedz
#7
W moim projekcie mam obraz z 2 kamer. 2 pliki z różnymi rozszerzeniami. Jeden obraz jest główny a drugi do przebitek.
Renderuje całość i plik z jednej kamery jet widoczny a z drugiej nie.

Kiedy wrzucę do nowego projektu sam plik to po zrenderowaniu jest niewidoczny.

Dzisiaj wieczorem zrobię test.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości