Problem z klatkami na sekunde w filmie.
#1
Ktoś wie jak renderować film, aby nie było czegoś takiego jak na tym screenie: http://zapodaj.net/3eac5c7603b0e.jpg.html ? Obraz jest rozmazany przy np. szybszych ujęciach.
Odpowiedz
#2
Wiemy:
- ustaw poprawnie projekt (wg plików wejściowych):
- ustaw poprawnie klatkaż,
- ustaw poprawnie przeplot (lub usuń);
- renderuj zgodnie z projektem.

Chcesz więcej szczegółów? Musisz Ty zacząć najpierw ;)
Odpowiedz
#3
Mateusz, niestety musisz dla mnie napisać jaśniej :D Może zrobimy tak. Podaję Tobie, jak i oczywiście innym osobom chcącym mi pomóc, linka do filmu bez renderowania w Vegasie. http://speedy.sh/4YDF7/00051.MTS - zobaczcie co można z tym zrobić i napiszcie jak mam to poprawic. Będę Wam bardzo wdzięczny ;)
Odpowiedz
#4
klip, który dałeś, jest 1920x1080 25klatek z przeplotem - czyli 50i.
Przeplot górny (Top Field First).

Przeplot właśnie powoduje to, że powstają "duchy" - ponieważ linie parzyste i nieparzyste sąprzesunięte w czasie o pół klatki (dlatego w zapisie jest 50i - czyli pięćdziesiąt półobrazów).

Zrób tak. Ustaw projekt (Project Properties) wg Match Media - na 1920x1080 25 itd. a następnie zmień przeplot (Field order) na None (progressive scan).
Dodatkowo ważne! - zmień metodę usunięcia przeplotu (Deinterlace method) na Interpolate fields...

Ewentualnie możesz użyć jakiegoś pluginu do usuwania przeplotu... i nałożyć na event... (Yadif Deinterlace - z tego co pamiętam jest darmowy).

Ps. Jak chcesz mieć podgląd o jakości wyrenderowanego filmu, to zmień sobie w ustawieniach podglądu na Best (Full)

Ps.
- materiał z kamery zgrywaj za pomocą dołączonego programu (łączy pliki w take'i, przez co przy dłuższych klipach - tych ponad 2GB; dostaniesz jeden wielki plik, bez brakujących klatek podczas łączenia, co się zdarza w przypadku ręcznego łączenia w programie do obróbki);
- jeśli nie rozumiesz któregoś pojęcia (szczególnie tych pogrubionych) - użyj magicznego przycisku [F1];
Odpowiedz
#5
Super dzięki wielkie za odp :D W podglądzie jest wszystko OK. Ale chyba, źle renderuję, ponieważ po zapisaniu jest tak samo :/ Jakiś rady ?
Odpowiedz
#6
Renderuj dobrze :)

Sony AVC, 1920x1080 25klatek, progresywnie (bez przeplotu)
Przepływność: 16Mbps
Odpowiedz
#7
Mateusz dzięki jeszcze raz! Wszystko jest tak jak należy! Pkt. reputacji oddany - chociaż tak się mogę odwdzięczyć. Pozdrawiam!
Odpowiedz
#8
Kolejna sprawa :) Jak dobrze "ustawić" projekt aby nie było tych "duszków" jeśli korzystam dodatkowo z filmów nagranych przez: Nikon D5000 i Gopro 2 czyli z 3 "sprzętów" na raz? Próbowałem róźnych opcji, ale się nie udało. Ma ktoś pomysł?
Odpowiedz
#9
Mam kolejny problem :/ Gdy do jednego "projektu" wrzucam filmy, które nagrane są przez kamere mając 25kl/sek i prze inną kamerę, która nagrywa 60kl/sek to podczas renderowania pojawia się "Problem report". Renderuje tak jak to opisał mateuszszar kilka postów wyżej. Może to wina kodeków? Próbowałem zmiejszyć ilość klatek z 60 na 25, ale nic to nie pomogło. Ktoś wie jak ten problem rozwiązać?
Odpowiedz
#10
Trochę zbyt mało danych napisałeś, żeby ktokolwiek był w stanie Ci pomóc... no chyba, że liczysz, że pomoże Ci ktoś, kto miał identyczny problem.
Jeśli pojawia się błąd, bo musi być jakaś przyczyna.
Renderujac np. do MainConceptAVC, często można dostać błąd, jeśli GPU jest czymś innym zajęte (jakiś inny program wspierający GPU), albo jeśli render nie pokrywa się z projektem (przypuszczam, że to tylko przy słabszych komputerach, bo mocniejsze pewnie potrafią pchnąć ten problem).

W Twoim przypadku, może to być mimo wszystko jakiś błąd w ustawieniu projektu. Albo nawet błąd GPU.
Trzeba by popróbować wyłączyć wszelkie wspomaganie GPU (w preferencjach programu jak również w ustawieniach renderu), - żeby wykluczyć błąd GPU.

Następnie, stworzyć nowy projekt, wrzucić pliki, dostosować projekt do plików (Match Media), a następnie puścić render. Jeśli nadal nie ma błędu... to jeszcze sprawa pluginów... które użyłeś.

Jeśli mieszasz 25p i 60p, to koniecznie zaznacz "disable resample" dla tych 60-cio klatkowych klipów. W innym wypadku, program z 60klatek zmiksuje 25, czyli w każdej klatce renderu znajdzie się 2.4klatki surówki :)

Jeśli Twoje 60klatek, to 60i a nie 60p, warto dodatkowo zastosować usunięcie przeplotu, choćby ustawiając w Vegasie metodę deinterlace'ingu - interpolate, chyba, że bardziej odpowiednia będzie dla Ciebie "blend fields", ale to już musisz sam sobie sprawdzić.
Do usunięcia przeplotu, możesz również użyć odpowiedniego pluginu (dla wszystkich klatek, które mają przeplot). Jest nawet darmowy plugin do tego (podawany na forum jakiś czas temu).
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Spowolnienie filmu z płynnością między klatkami rafalovy 9 4,442 04-28-2013, 21:40
Ostatni post: je2bisty
  Problem ze zmianą klatek na sekundę jezin 1 663 02-14-2013, 23:48
Ostatni post: moonscape
  Problem z "wcinającymi się" klatkami. Kricz 5 1,362 11-29-2010, 13:42
Ostatni post: Kricz

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości