Samoistne przesuwanie się pojedyńczych klatek
#1
Witam!
Mam problem podczas obrabiania materiałów nagranych kamerą Praktica w Movie Studio 11 Platinum. Zapisuje ona w formacie AVI. Problem polega na tym, że przy stosowaniu normalnych działań typu przesuwanie filmów, tworzenie przejść między filmem, a filmem bądź filmem innym klipem, przesuwają się pojedyncze klatki z plików AVI. Objawia się to tak, że na przykład po przesunięciu gdzieś i stworzeniu przejścia z klipem, w którymś jego momencie nagle pojawia się klatka, która powinna się pojawić dopiero sekundę później. Wygląda to na przykład tak, że ktoś na filmie się schyla i w pewnym momencie jest migawka jak jest już schylony, a za chwilę schyla się dalej. Po przybliżeniu klipu tak, że można działać na pojedynczych klatkach, tę klatkę tam rzeczywiście widać i można ją wyciąć i złączyć film, tak że leci płynnie. Jednak ponieważ dzieje się to praktycznie przy każdym pojedynczym klipie, jest to niezwykle czasochłonne i irytujące. Również przy przejściach między filmami się tak dzieje. Tam wygląda to czasem tak, że gdy już prawie w 100% widoczny jest drugi film, wpada na 100% widoczności klatka z filmu poprzedniego, psując efekt.

:-)
Odpowiedz
#2
Możliwe, że to co napisałem nie jest szczególnie zrozumiałe, tym bardziej jeśli ktoś tego nie widział na własne oczy, więc wrzucam przykład takiego zachowania programu:



Może teraz będzie łatwiej zrozumieć o co z tym chodzi...
Proszę o pomoc! Aktualnie pracuję nad filmem i termin się zbliża, a przeskakujące klatki bardzo utrudniają mi pracę :(


EDIT:
Właśnie odkryłem kolejny problem w tym temacie. Otóż okazuje się, że wystarczy, że jeden event jest nad drugim na dwóch ścieżkach i już pojawiają się przeskakujące klatki. W programie wygląda to tak:
http://i48.tinypic.com/3523i9h.jpg

A efekt jest następujący:
Odpowiedz
#3
Przyspieszałeś te filmy, nieprawdaż? Właśnie w tym czuję problem patrząc na screena.
Odpowiedz
#4
Niektóre tak, ale to nie ma żadnego znaczenia, bo problem pojawia się przed jakimikolwiek zmianami. Wystarczy wstawić filmik, przesunąć go albo przyciąć i BOOM, już widzę że gdzieś jest niepożądana klatka...
Odpowiedz
#5
Kupując kamery-wynalazki, trzeba być przygotowanym na różne cuda. Przekonwertuj materiał do innego formatu, np. do AVI Lagarith.
Odpowiedz
#6
Spróbuję... A jaki konwerter będzie odpowiedni. Żeby nie tracić jakości. Gdzieś na forum wpadła mi w oko pewna nazwa, ale nie jestem pewien czy to o ten chodziło: MovAvi.
Odpowiedz
#7
Plik wejściowy masz w AVI, więc sugeruję sprawdzonego i niezawodnego VirtualDuba, który w sumie konwerterem nie jest, ale doskonale się do tego nadaje.

Maciej Lewandowski - efix.pl
Odpowiedz
#8
Nie wiem jaki masz sprzęt, ale spróbuj jeszcze wyłączyć wielowątkowy rendering ustawiając w opcjach wideo "maximum number of rendering threads" na 1.
Odpowiedz
#9
Panowie, a nie zastanawialiście się że jest "coś nie tak" na tym obrazku.
I tu leży przyczyna
http://i48.tinypic.com/3523i9h.jpg
Odpowiedz
#10
Heh, no tak... Jak to mowią, rutyna zabija a pewne rzeczy wydają się oczywiste...

Maciej Lewandowski - efix.pl
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Samoistne podświetlenie w Sony Vegas Pro 11 Neoxyh 2 579 02-19-2014, 17:11
Ostatni post: Neoxyh
  Film ciemniejszy po renderingu od pojedynczych klatek KJS 1 1,371 04-16-2012, 22:25
Ostatni post: efix
  samoistne(?) rozjaśnienie obrazu po renderowaniu MbM 4 1,723 04-02-2012, 0:47
Ostatni post: Pinto

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości