Niechciane artefakty - Jaki kodek wybrać do renderowania w moim przypadku
#1
Witam, to mój premierowy post na forum, pozwólcie więc że się przywitam - a więc Witam :-)

Zacząłem niedawno przygodę z SV11 no i jak to często bywa w początkach napotkałem na problem - postaram się w miarę krótko i klarownie go opisać

Przejdźmy do rzeczy:

1. Materiał wyjściowy który otrzymuję do zabawy to video w formacie .mov 720p 1280x720 przy 30fps (z apartatu Canon SX 130 )

2. W związku z tym, że materiał w tym formacie zajmuje 4-5 razy więcej niż to samo w avi przy praktycznie niezmienionej jakości, przerabiam materiał nie zmieniając rozdzielczości ani ilości kl/s na avi - używam kodeka XviD.

3. Dopiero otrzymanym materiałem avi bawię się w Vegasie. Są to to krótkie 3-4 minutowe filmy, które łączę - dodaję miedzy nimi przejścia, te które dodał producent pod zakładką transitions, jakieś proste intro na początku + napisy końcowe.

4. Problem mam właśnie przy stosowaniu wspomnianych transitions i napisów końcowych (konkretnie klasyczne credit roll)

Otóż, kiedy gotowy projekt renderuję (nadal nie zmieniam wartości kl/s i rozdzielczości, render do avi XviD, korzystam z najnowszej wersji tego codeca) efekt jest taki, że w momentach przejść pomiędzy poszczególnymi klipami i przy napisach końcowych, na kilku klatkach pojawiają się artefakty - najczęściej taka kolorowa pikseloza.

Kiedy projekt renderuję np. do 50kl/s problem znika, ale wtedy film staję się jakby nienaturalny, zdecydowanie lepiej wygląda w 30kl/s nie mówiąc już o mniejszej wadze, i krótkim czasie renderowania, bo program renderuje tylko dodane elementy a nie cały film.

Co mogę zrobić żeby pozbyć się owych artefaktów?

Może zastosować jakiś inny kodek?

A może przy 30kl/s powyższe efekty transitions są po prostu niemożliwe do wykorzystania bez pojawiania się artefaktów?


Odpowiedz
#2
Próbowałeś odtworzyć to w różnych playerach? Być może to wina ze strony odtwarzacza?
Odpowiedz
#3
Zamiast do Xivida sprobuj kodowac najpierw koduj do DV. Tez bedzie zajmowac troche, ale nie tyl co mov
Odpowiedz
#4
@Piciu - tak otwierałem BestPlayerem i Media Player Classic ale w obu był taki sam efekt.

Zrenderowałem materiał do MainConcept AVC/AAC -> Internet HD 720p (mp4) i wydaje się że problem został rozwiązany - tylko w 1 z 23 przejść mam malutkie piksele.

Później z ciekawości jeszcze raz zrenderowałem materiał mp4 tym razem do pożądanego przeze mnie avi (pożądanego gdyż np. na stacjonarnym dvd nie otworzę innego innego formatu oprócz dvd i właśnie avi) i co ciekawe artefaktów też już nie ma :)
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Spowolnienie filmu a fps materiału wyjściowego + artefakty na materiale wyjściowym kr1st0 1 439 04-03-2015, 20:01
Ostatni post: koks
  Artefakty i haczenie po renderingu do Pal DVD Video Stream Skrzypiec 7 1,405 12-22-2014, 19:18
Ostatni post: Skrzypiec
  Renderowanie do AVI - jaki kodek? chris996 2 898 11-24-2014, 21:54
Ostatni post: chris996
  Jaki kodek do renderowania dźwięku na B-R Piwosz 3 870 10-27-2014, 23:07
Ostatni post: mateuszszar
  jaki sprzet wybrac do zabawy z Vegasem zukul113 8 1,630 10-01-2014, 21:04
Ostatni post: efix
  Jaki najlepszy i najszybszy kodek do AVI? elektryk70 3 3,145 08-30-2013, 0:51
Ostatni post: mateuszszar

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości