Obraz jest, dźwięku nie ma.
#1
Robię film na projekt z polskiego i mam problem - cały projekt składa się z 2 ścieżek: narracji i ścieżki z filmem. Problem w tym, że film się normalnie wyświetla, a dźwięku w ogóle nie ma (żadnych kresek, tak jakby film był niemy). Właściwości klipu z zakładki "General":
Cytat:General
Name: klip.avi
Folder: nieważne :P
Type: Video for Windows
Size: 5,42 MB (5 547 522 bytes)
Created: 25 kwietnia 2012, 09:27:31
Modified: 25 kwietnia 2012, 09:27:45
Accessed: 25 kwietnia 2012, 09:27:31
Attributes: Archive

Streams
Video: 00:00:23,840, 25,000 fps, 320x176x24, Xvid MPEG-4 Codec
Audio: 00:00:00,000, 22,050 kHz; Stereo,

Summary
Software: Lavf52.94.0

ACID information
ACID chunk: no
Stretch chunk: no
Stretch list: no
Stretch info2: no
Beat markers: no
Detected beats: no

Other metadata
Regions/markers: no
Command markers: no

Media manager
Media tags: no

Plug-In
Name: aviplug.dll
Folder: E:\sony vegas 11\FileIO Plug-Ins\aviplug
Format: Video for Windows
Version: Version 11.0 (Build 594)
Company: Sony Creative Software Inc.
Jak to dalej nic nie wyjaśnia, to dla pomocy zrzut okienka ze ścieżkami:
[Obrazek: 30jlbw5.png]
Odpowiedz
#2
A skąd masz takie nagranie? Dźwięk próbkowany 22.050Hz?
Widać we właściwościach, że długość ścieżki audio: 0s.
W odtwarzaczu normalnie słychać dźwięk?
Daj informacje z MediaInfo - na temat tego pliku. Albo jakiś dziwny kodek, którego Vegas nie widzi (kodek audio oczywiście), albo się nic nie nagrało, stąd stream o długości 0s.
Odpowiedz
#3
Ściągałem YTD "YouTube Downloader & Converter", potem konwertowałem z FLV -> AVI. W odtwarzaczu słychać dźwięk. Jak te informacje z mediainfo zdobyć? Bo jestem nowicjuszem i jeszcze nie pojmuję tego wszystkiego :P.
Odpowiedz
#4
Daj link do YT - jeśli możesz.
Ja zawsze pobieram pliki z YT w ten sposób, że otwieram IE, ustawiam najlepsza jakość, po zbuforowaniu, plik video pojawia się w Temporary Internet Files. Trzeba tylko zidentyfikować, który to, ale jeśli utrzymujemy porządek na komputerze, a IE czyści się sam po zamykaniu, to nie ma z tym najmniejszego problemu.

Jakie masz kodeki w systemie? Bo jak instalowałeś K-lite, to prawdopodobnie masz MediaInfo.
Jeśli nie, możesz pobrać ze strony. Jest darmowy.

Problem może być w tym programie, za pomocą którego konwertowałeś. Nie wiem, czy ten program ma jakieś ustawienia co do plików wyjściowych? Powinien mieć... a jeśli tak, to wypadało by sprawdzić na innych ustawieniach (np. nieskompresowany dźwięk - tzw. PCM, albo MP2, MP3... i koniecznie w lepszych parametrach: 44.100Hz lub 48.000Hz).
Odpowiedz
#5
(04-27-2012, 18:37)mateuszszar napisał(a):  Daj link do YT - jeśli możesz.
Ja zawsze pobieram pliki z YT w ten sposób, że otwieram IE, ustawiam najlepsza jakość, po zbuforowaniu, plik video pojawia się w Temporary Internet Files. Trzeba tylko zidentyfikować, który to, ale jeśli utrzymujemy porządek na komputerze, a IE czyści się sam po zamykaniu, to nie ma z tym najmniejszego problemu.

Jakie masz kodeki w systemie? Bo jak instalowałeś K-lite, to prawdopodobnie masz MediaInfo.
Jeśli nie, możesz pobrać ze strony. Jest darmowy.

Problem może być w tym programie, za pomocą którego konwertowałeś. Nie wiem, czy ten program ma jakieś ustawienia co do plików wyjściowych? Powinien mieć... a jeśli tak, to wypadało by sprawdzić na innych ustawieniach (np. nieskompresowany dźwięk - tzw. PCM, albo MP2, MP3... i koniecznie w lepszych parametrach: 44.100Hz lub 48.000Hz).
A znasz jakiś dobry program do konwersji i ściągania (nie mam IE) plików z YT? Taki, po którym Sony Vegas nie będzie świrować, najlepiej sprawdzony :).
Odpowiedz
#6
Takie rzeczy tylko w Erze... ;)

Vegas w większości przypadków uzależniony jest od kodeków, które mamy w systemie. Jeśli takich nie ma (odpowiednia wersja 32 lub 64bitowa), to Vegas po prostu nie otworzy. itd.

Pliki na YT zazwyczaj są zakodowane AVC + dźwięk AAC.
Vegas nie ma problemów ani z tym, ani z tym.
Problem natomiast może być jeszcze inny. Zależy, w jaki kontener jest to zapakowane. Jeśli MP4 - to nie będzie raczej problemów. Jeśli FLV - to lipa - trzeba przekodowywać.

Moja propozycja: jeśli nie masz InternetExplorer'a, ściągnij Freemake Video Converter - jest darmowy: http://www.freemake.com/
Wklejasz link z YT, i wybierasz np. MP4 lub WMV (lub MPEG2)... i dostajesz plik, który powinien ruszyć.
Odpowiedz
#7
(04-27-2012, 19:03)mateuszszar napisał(a):  Takie rzeczy tylko w Erze... ;)

Vegas w większości przypadków uzależniony jest od kodeków, które mamy w systemie. Jeśli takich nie ma (odpowiednia wersja 32 lub 64bitowa), to Vegas po prostu nie otworzy. itd.

Pliki na YT zazwyczaj są zakodowane AVC + dźwięk AAC.
Vegas nie ma problemów ani z tym, ani z tym.
Problem natomiast może być jeszcze inny. Zależy, w jaki kontener jest to zapakowane. Jeśli MP4 - to nie będzie raczej problemów. Jeśli FLV - to lipa - trzeba przekodowywać.

Moja propozycja: jeśli nie masz InternetExplorer'a, ściągnij Freemake Video Converter - jest darmowy: http://www.freemake.com/
Wklejasz link z YT, i wybierasz np. MP4 lub WMV (lub MPEG2)... i dostajesz plik, który powinien ruszyć.
Dzięki gościu, jesteś wielki :).

@EDIT jak drugi raz coś konwertuję to już dźwięk nie działa, jest taki piszczący (i w programie i w odtwarzaczu).
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z zapisanym projektem - czarny obraz, brak dźwięku ZAFIRa 10 774 01-18-2016, 0:04
Ostatni post: ZAFIRa
  Krótki obraz względem dźwięku wiara 10 2,503 06-18-2012, 15:22
Ostatni post: wiara
  Brak dźwięku, chociaż jest nagrany. Ratajello 1 1,558 04-08-2012, 19:56
Ostatni post: Piciu
  Rozdzielenie dżwięku - czy jest mozliwe? nikita13 4 2,106 01-03-2012, 12:55
Ostatni post: mateuszszar

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości