Czy DiVX się starzeje i rozkłada?
#1
Dziwny problem.

Całe życie [od 2 lat] renderuje filmy w ten sam sposób w Vegasie, przy tych samych ustawieniach na Divx 5.0.5, mp3. Wszystko zawsze jest dopieszczone co do milisekundy.

Nagle po 2 latach zacząłem zauważać że niektóre filmy mają inną synchronizacje audio/video.

Na filmach słowa można usłyszeć zanim widzi się otwieranie ust. Dźwięk jest odtwarzany około pół sekundy za wcześnie.

Czy to znaczy że wszystkie moje późniejsze rendery też zaczną się rozjeżdzać ?

Jak mam to w ogóle rozumieć ? Pracuje nad filmem, montuje go, renderuje, działa idealnie a za rok działa inaczej ? Czary mary ?

Czy ktoś zna jakieś wytłumaczenie tego 'buga' ?

Pliki trzymam w wielu miejscach, głownie na HDD.
Weźmy na sprawdzenie jeden z nich, AVI 25fps.
Załadowałem plik z dysku twardego.
Audio wchodzi 7 klatek za wcześnie = 0.28 sekundy
Sprawdziłem ten sam film, ale jako plik z CD wypalonej 2 lata temu dla backupu.
To samo.
To samo z innym filmem. Też 7 klatek.

Wygląda na to że pewnej nocy Divx zdecydował że obraz w niektórych plikach popchnie sobie 7 klatek do przodu, lub MP3
zdecydowało że cofnie sie 7 klatek do startu. WHAT THE FU*K.

Oto wgląd z info z VirtualDub:

[Obrazek: 14xmf5s.jpg]

Czyżby nagle Fraunhofer stał się niekompatybilny z atomowym zegarem świata ?

Zaznaczam że dzieje się to narazie w 2 filmach. Cała reszta renderowana na tych samych ustawieniach trzyma sync dobrze.
Odpowiedz
#2
A może coś ci wolno komp chodzi?
Format c: - zawsze pomaga
Odpowiedz
#3
(06-04-2009, 19:56)qatryk napisał(a):  A może coś ci wolno komp chodzi?
Format c: - zawsze pomaga

nie no
juz jestem po zmianie komputera nawet na nowy
poza tym wrzucam plik do vegasa i tam wszystko widać
wykres na ścieżce audio zaczyna sie za wczesnie

moze po polsku mi to tłumaczenie pokracznie wychodzi wiec dodatkowy wgląd po angielsku;

I've been rendering movies in Sony Vegas for the past 2 years, always using the same settings.
Divx 505 and Fraunhofer IIs. You can see the full settings in the enclosed JPG.

I am very precise and my videos are edited within miliseconds.
Some time ago I noticed that my old videos [approximately 2 years old] have bad audio/video sync.
The audio is played too early. 7 frames [0,28 second] before the time it should play judging from original edit.

To make things even more strange, this problem affects only several of my videos. There are other videos which have been rendered with exactly the same settings, but they keep the audio/video in sync.

How is it possible that a video, that was produced well, and used to play well, now after some time behaves differently?
If I did not make any modifications, and I did not, the files were just sitting on the hard drive - then what caused the audio track to shift in relation to video track?
Odpowiedz
#4
To sprawdź na innym sprzęcichu, divixie, prze konwertuj, Fotmat c:
Odpowiedz
#5
A czemu akurat DIvX'em? Jest przecież masa innych, a wracając do pytania to masz najnowszą wersję? Może coś się zmienilo i nikt nikogo o niczym nie informował ;p
Nie udzielam odpowiedzi na PW.
Odpowiedz
#6
no i to nie jest sprawa "różne playery, rózne kodeki"

te ścieżki są zamienione na zawsze

to tak jakby odpruć nogawkę ze spodni i przyszyć ją ale już w innym miejscu


oto orientacyjny wykres jaki spreparowałem aby ułatwić wizualizację w głowie

[Obrazek: 200wy7p.jpg]
Odpowiedz
#7
Może się i DiVX starzeje. Ale nie lepiej [CTRL]+[a] i przesunąć dźwięk.
Odpowiedz
#8
(06-06-2009, 10:05)qatryk napisał(a):  Może się i DiVX starzeje. Ale nie lepiej [CTRL]+[a] i przesunąć dźwięk.

Na dysku jasne że lepiej, jeden ruch, jeden render i po kłopocie.

Ale problem jest o tyle duży, że ten klip został 2 lata temu opublikowany na Youtube, no i od kliku dni właśnie na Youtubie jest rozjechana synchronizacja A/V, mimo że przez cały ten czas grało idealnie, tak jak idealnie zostało wyprodukowane i zuploadowane...

Niech sie psuje u mnie, bo np. zmieniam kompa. Albo niech sie psuje na Youtubie, bo np. zmieniają serwery. Ale ten sam problem w tym samym czasie i tu i tu ?
Odpowiedz
#9
a jeśli chodzi o yT to jest opcja podmień dzwięk ;)
Odpowiedz
#10
Albo daj linka na YT
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości