Problem z formatem (.MOV)
#1
Witam

Mam dość irytujący problem związany z formatem .MOV (quicktime). Pracuję na wersji 8.0 i za każdym razem jak próbuję importować plik w formacie .MOV (w takim właśnie zapisuje moja kamera - niestety) jest on od początku do końca czarny, a ścieżka dźwiękowa jest płaska, więc nie ma audio. Kiedy otwieram taki plik w zwykłym Playerze to wszystko chodzi bez problemów, jest dźwięk i obraz, jednak w SV dzieje się tak jak wyżej opisałem. Dotychczas chcąc to ominąć konwertowałem dany plik .MOV na AVI, wykorzystując program AVC (Audio Video Converter) i wrzucałem do programu. Mija się to jednak z celem gdyż tracę strasznie dużo czasu na tą całą konwersję :( i na jakości trochę też, a o wiele łatwiej by było mi montować surowe pliki .MOV w SV i później renderować cały projekt. Kodeki jakie mam zainstalowane to popularny K-Lite Codec Pack.

Czy ktoś z Was miał podobny problem i go rozwiązał?

Pozdrawiam, K
Odpowiedz
#2
Cytat:Kodeki jakie mam zainstalowane to popularny K-Lite Codec Pack.
Sam sobie odpowiedziałeś co jest nie tak ;]

Przeczytaj ten topic. Nie klikaj w nim w żadne linki. Przeczytaj najpierw całość. 3 strony są i zobacz co robisz źle :)
Nie udzielam odpowiedzi na PW.
Odpowiedz
#3
Przeczytałem polecony przez Ciebie temat i zastosowałem się do wskazówek, czyli:

- Odinstalowałem kodeki
- Wyczyscilem je rejestru
- zainstalowałem: ffdshow, quicktime alternative, ac-3
- zastosowałem twoje ustawienia ffdshow

Niestety nie zadziałało więc, odinstalowałem i zainstalowałem ponownie SV 8.0, i nic się nie zmieniło. Pliki bez problemu odpalają mi się w WMP 12, który jest standardowo zainstalowany, a w SV plik jest cały czarny po przeciągnięcia ;o. Nie wiem dlaczego z tymi nowymi kodekami jest tak samo jak było ;o . Film powinien się odtwarzać w SV jak chodzi w WMP :/. Są jeszcze jakieś inne możliwości ?
Odpowiedz
#4
Możesz przekonwertować plik na AVI polecam programem Any Video Converter.
Odpowiedz
#5
Hehehe robiłem to do tej pory :P dlatego też napisałem na forum bo myślałem, że da się to jakość obejść. Zrobiłem jeszcze rozeznanie na zagranicznych forach/stronach i okazuje się, że w niektórych przypadkach pozostaje tylko konwersja ;o nad czym ubolewam.
Odpowiedz
#6
Z jakiejś kamery masz te MOV tak? Może kamera jest jakaś dziwna, i Vegas nie rozumiem kontenerka MOV ;D
Nie udzielam odpowiedzi na PW.
Odpowiedz
#7
No właśnie chodzi, że z kamery (TOSHIBA Camileo s10) i chyba już nic z tym nie zrobię. Pozostaje tylko płacz i konwersja :D.

Aha i mam pytanie jakie ustawienia trzeba dać przy konwertowaniu np. na mp4 żeby nie stracić na jakości :>? Czy w ogóle tak się da, żeby nie traciło? Filmiki głównie na youtube chce wrzucać. Kiedyś przerabiałem na AVI (xvid), a zauważyłem że na mp4 o wiele mniej zajmują przy x264.
Odpowiedz
#8
Cytat:a zauważyłem że na mp4 o wiele mniej zajmują przy x264.
Mniej zajmują, ale Vegas więcej się musi napracować nad ich odczytem i czasami zauważyłem jakieś dziwne błędy z obróbką plików mp4, nagle czarny obraz mimo, że plik jest dobry, etc.

Ja proponuję eksportować do nieskompresowanego AVI, wtedy nie tracisz nic na jakości. Co prawda zajmuje wtedy bardzo dużo miejsca, ale jakość masz identyczną jak tą w plikach MOV. A potem możesz je przecież usunąć; albo dokup sobie dodatkowy dysk gdzie będziesz trzymał tylko video do Vegasa. Montaż to nie tania sprawa :]
Nie udzielam odpowiedzi na PW.
Odpowiedz
#9
Dzięki tomi, że napisałeś o tych problemach z plikami mp4. Nie będę ich konwertować na ten format choć tak planowałem :P. Zaoszczędzę pewnie sporo swojego i Waszego czasu bo pisał bym zapewne na forum jak by coś przestało hulać xD.

Mam jednak pytanie odnośnie tej kompresji na AVI , bezstratnej jak powiedziałeś.
Więc, używam programu wymienionego wyżej przez rmxprzemo już od jakiegoś czasu. Jednak nie wiem jaki mam ustawić kodek, oraz parametry pliku wyjściowego. Na załączonym obrazku widać okno programu i po prawej stronie parametry konwersji:

[Obrazek: avcl.jpg]

Jeżeli chodzi o rozdzielczość to ustawiam taka jaka jest oryginalna, tak samo ilość klatek. Nie jestem jednak pewien co do bitrate i jakiego kodeka użyć a, żeby nie stracić na jakości. Proszę o podpowiedź :D
Odpowiedz
#10
Serio, nie możesz sobie wyciąć z 10 sekund tego filmu, wyrenderować go kilkoma kodekami i sprawdzić w jakich warunkach dany kodek lepiej działa? Już byś to dawno zrobił :> Wyrenderuj jeden do mjpeg, x264, huffyuv i jeden do np. h263p i zobacz co "lepiej wygląda" albo wybierz Orginal.
Nie udzielam odpowiedzi na PW.
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z formatem RMVB BILBO 7 1,849 02-02-2010, 14:42
Ostatni post: tomislater

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości