Asynchron dźwięku z obrazem
#1
Cokolwiek robię w Vegas to po renderowaniu dźwięk mam niedopasowany do obrazu. Wchodzi albo za wcześnie albo za późno, chociaż w podglądzie jest OK. Co mam zrobić?
Odpowiedz
#2
Czytać najpierw regulamin forum?
Odpowiedz
#3
Nie rozumiem.
1) Tytuł wątku jest bardzo precyzyjny, w przeciwieństwie do wielu wątków w stylu "Mam problem! Co robić k..wa?!", które jakoś usuwane nie są.
2) Wątek jest umieszczony w odpowiednim dziale.
3) Przeszukałem forum i nie znalazłem takiego pytania, nie mówią już o odpowiedzi.
Więc może pomożesz mi, zamiast pisać takie bzdurki? :)
Odpowiedz
#4
Podaj więcej informacji. Do jakiego formatu renderujesz, jakim kodekiem dźwięk, a jakim video. Ile ustawiasz fps, rozdzielczość, etc :V
Nie udzielam odpowiedzi na PW.
Odpowiedz
#5
Nie podałeś misiu żadnych informacji, mamy wróżyć z fusów? Wielokrotnie o tym była mowa.
Odpowiedz
#6
aaa, no w sumie... przepraszam :D
plik oryginalny to scalony z napisami 25 minutowy plik .avi
nie znam się zbyt dobrze, mam nadzieję, że wszystko podam:

w sony renderuję jego 5-minutowy fragment (próbowałem go wydzielić na oba sposoby - 1. tylko zaznaczając i renderując fragment oraz 2. wycinając resztę i renderując, co zostało -> rezultat końcowy ten sam - asyn) na .wmv w rozdzielczości 720-24p 4.8 Mbps (HD)
Audio: 192 Kbps, 48 000 Hz, 16 Bit, Stereo, WMA9.
Video: 23.976 fps, 1280x720, WMV V9 CBR Compression, Smoothness 90.
Field order: none (prog)
pixel aspect ratio: 1.0 (square)
pixel format: 8-bit
full-resol rend quality: best
motion blur type: gaussian
deinterlace method: none

Jakość piękna, w pół godziny zrobione, więc chyba nie tak źle.
Tylko ten asynchron gdzieś o 1 sekundę.
Odpowiedz
#7
Cytat:720-24p
Cytat:Tylko ten asynchron gdzieś o 1 sekundę.
Przypuszczam, że materiał wejściowy masz w 25 kl/s :) Renderuj również do 25 klatek na sekundę, a nie 23.976.
Nie udzielam odpowiedzi na PW.
Odpowiedz
#8
nic nie dało, ten sam asynchron :(( a zmieniłem zarówno w properties, jak w preferences i przed samym renderingiem

dźwięk idzie równo cały czas, obraz też. tylko, że dźwięk jest przesunięty i wchodzi o sekundę wcześniej, niż obraz. ale zanim renderuję, na podglądzie jest wszystko super
Odpowiedz
#9
Za każdym razem dźwięk jest wcześniej o sekundę? Spróbuj na ścieżce dźwięk przesunąć do przodu o sekundę;) Rada trochę naokoło, ale zawsze to jakieś rozwiązanie, nawet jeśli tymczasowe.
Trochę strzelam... Problem może tkwić w różnicy bitrate między filmem a dźwiękiem - poszperaj w ustawieniach. Spróbuj też dźwięk wydzielić i zapisać go jako nieskompresowany wav i potem dodać do filmu.
P.S. Czy jak renderujesz tylko fragment dla podglądu (w pamięci), też jest ok?
Odpowiedz
#10
Dobry pomysł :D Oczywiście pomogło, bo musiało pomóc. Ale tak, jak mówisz, to tylko tymczasowe rozwiązanie.
Z tą resztą to spróbuję jutro, bo dziś nie będę miał czasu.
Dzięki :)

ad. PS. Nie wiem, co to render dla podglądu. Czyli po prostu okienko podglądu w projekcie? No tak, wtedy jest OK.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości