DVD Architect7 nie importuje .m4v
#1
Tworzę płytę BD w DVD Architect 7 i 6 i przy imporcie pliku video .m4v otrzymuję komunikat "the selected file is not of the required type" czyli, że wybrany plik nie jest wymagany :-( Oczywiście przed importem wybieram szablon projektu "Blu-ray AVC".
Gdy importuję plik .m2v do projektu "Blu-ray MPEG2" to import przebiega pomyślnie.
Gdyby ktoś znał przyczynę niepowodzenia importu pliku .m4v to proszę o pomoc.
Odpowiedz
#2
A czym tworzyłeś ten plik M4V? W instrukcji DVD Architect nie ma słowa o tym, że przyjmuje pliki M4V... chyba, że coś przeoczyłem. Daj odczyt z MediaInfo, co siedzi w tym pliku M4V.

Ewentualnie (jeśli plik jest zgodny z BluRay), zmień rozszerzenie na MP4, lub przemuxuj do MP4.
Odpowiedz
#3
Plik .m4v zrenderowałem Adobe Premiere CC 2015 presetem H264 Blu-ray, czyli standardowym dajacym plik video .m4v i audio .ac3. W okienku importu Architecta nie ma rozszerzenia .m4v ale jest rozszerzenie .m2v jest i to mi otwiera. Może to brak jakiegoś np. quicktimowego kodeka :-( Spróbuję zmienić rozszerzenie na .mp4.
Odpowiedz
#4
Przemuxuj do MP4 - i DVD Arch. powinien łyknąć.
Wiesz co? U mnie pliki m4V wczytują się do DVD Arch 7. Może faktycznie to sprawa QuickTime'a?
Po zmianie rozszerzenia działa u Ciebie?
Odpowiedz
#5
Co znaczy "przemuxuj"... objaśnij w kilku słowach.
Odpowiedz
#6
Ok. Przerenderowałem Premierką do M4V - i faktycznie DVD Arch nie widzi.
Zmieniłem ręcznie rozszerzenie - na MP4 -> DVD Arch zassał video oraz audio (z innego pliku o tej samej nazwie - z rozszerzeniem AC3).

Czyli jest rozwiązanie :)
Odpowiedz
#7
Dzięki Mateusz za pomoc. Jutro to sprawdzę bo teraz piszę z pracy. Myślę, że jak zadziałało u Ciebie to i mnie zadziała. Napiszę wieczorem. Dzięki wielkie!
Odpowiedz
#8
muxowanie - to zmiana kontenera, bez rekodowania strumieni.
Plik MP4, to tak na prawdę "paczka" (kontener), w którym znajdują się strumienie VIDEO (np. zakodowane h.264) oraz strumienie audio (np. MP2, AAC lub AC3).
Muxowanie, to nic innego, jak wyciągnięcie strumieni, oraz ponowne złożenie do kontenera.
Są specjalne programy (typu TsMuxer), które robią takie rzeczy. Czy choćby MKV Muxer - ten tworzy pliki MKV (nie koduje materiału, zmienia tylko kontener).

Czasami się zdarza, że plik jest źle "złożony". Strumienie są OK, ale kontener ma problem. Albo - jak teraz - rozszerzenie jest niepoprawne dla danego programu. Wówczas wystarczy przemuxować.

Czasami chamska zmiana rozszerzenie nie działa. Dlatego używamy muxowania.
W tym przypadku wystarczyło jednak zmienić rozszerzenie w exploratorze windows :)

Dokładnie tak samo jest z AC3 - który jako pojedynczy plik, nie można wczytać do VEGASA. Ale jak przemuxujesz do TS lub M2TS - vegas łyka nawet jako multitrack 5.1.
Dla plików zgodnych z DVD/BluRay - jest program TsMuxer.
Odpowiedz
#9
Dzięki za wyczerpujący wykład. Teraz już wiem co to muxowanie.
Odpowiedz
#10
Zmieniłem ręcznie rozszerzenie pliku .m4v (tego zrenderowanego w Premiere CC) na .mp4 i Architect 7 zaimportował plik video i audio - czyli jest ok. Czyżby to oznaczało, że Sony zabezpieczyło się przed korzystaniem z plików powstałych w Premiere :-( Kiedy chciałem przemuxować plik .m4v do .mp4 to tsMuxeR 2.6.12 nie otworzy pliku o takim rozszerzeniu. Nie ma w nim tego rozszerzenia wśród obsługiwanych plików.
Mam jeszcze jeden problem. Kiedy finalnie renderuję kompilację w Architekcie 6 i 7 mniej więcej w połowie kompilacji wyskakuje mi błąd: "Video buffer underflows" (niedobory bufora, bufor przepełniony - coś takiego) i oczywiście Architect przerywa pracę. Scren z tym komunikatem w załączniku.
   
Może należy zwiększyć rozmiar jakiegoś bufora w Architekcie. Pamięci operacyjnej mam 12 GB, może to za mało :-( Materiał zaimportowany do Architecta to 1920x1080 50i 20 Mbps. Przy finalizacji Architect podaje, że audio i video jest no-compress.
Problem taki był opisywany tu:

http://sonyvegas.info/thread-9865.html?h...+architect

Rozwiązaniem problemu było obniżenie bitrate z 40 Mbps na 39,9 Mbps. U mnie zaimportowany materiał ma 20 Mbps i problem występuje.
Proszę o poradę...
Odpowiedz



   


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Sony Vegas pro 10 nie importuje filmów z Toshiba Camileo x100 MARCIN3322 12 4,364 10-18-2011, 20:44
Ostatni post: chemip

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości