Przycinanie się filmiku po renderingu
#1
Witam,

Próbuję połączyć filmik z plikiem audio. Po renderingu od pewnego momentu wideo przestaje być płynne i dostaje lekkiej przycinki ale tylko obraz, audio zostaje bez zmian.

Posiadam program Sony Vegas 13 (build 290) 64bit.

Plik wejściowy:
General
Pełna ścieżka                           : C:\Users\micha\Desktop\Nowy numer\Video2.mp4
Format                                  : MPEG-4
Profil formatu                          : Base Media / Version 2
ID kodeka                               : mp42 (isom/mp42)
Rozmiar pliku                           : 546 MiB
Czas trwania                            : 4 min 25 s
Całkowita przepływność bitów            : 17.3 Mb/s
Zdekodowana data                        : UTC 2018-10-13 16:47:08
Znakowana data                          : UTC 2018-10-13 16:47:08
com.android.version                     : 7.0

Video
ID                                      : 1
Format                                  : AVC
Format/Informacja                       : Advanced Video Codec
Profil formatu                          : High@L4
Ustawienia formatu                      : CABAC / 1 Ref Frames
Ustawienia formatu, CABAC               : Yes
Ustawienia formatu, poklatkowy          : 1 frame
Format_Settings_GOP                     : M=1, N=30
ID kodeka                               : avc1
ID kodeka/Informacja                    : Advanced Video Coding
Czas trwania                            : 4 min 25 s
Source_Duration/String                  : 4 min 25 s
Przepływność bitów                      : 17.0 Mb/s
Szerokość                               : 1 920 pixels
Wysokość                                : 1 080 pixels
Proporcje obrazu                        : 16:9
Tryb wyświetlania klatek                : Variable
Szybkość wyświetlania klatek            : 30.000 FPS
Minimalna szybkość wyświetlania klatek  : 23.892 FPS
Maksymalna szybkość wyświetlania klatek : 35.322 FPS
ColorSpace                              : YUV
ChromaSubsampling/String                : 4:2:0
BitDepth/String                         : 8 bits
Rodzaj skanu                            : Progressive
bity/(piksele*ramki)                    : 0.273
Rozmiar strumienia                      : 538 MiB (98%)
Source_StreamSize/String                : 538 MiB (98%)
Tytuł                                   : VideoHandle
Język                                   : English
Zdekodowana data                        : UTC 2018-10-13 16:47:08
Znakowana data                          : UTC 2018-10-13 16:47:08
mdhd_Duration                           : 265387
Codec configuration box                 : avcC

Audio
ID                                      : 2
Format                                  : AAC LC
Format/Informacja                       : Advanced Audio Codec Low Complexity
ID kodeka                               : mp4a-40-2
Czas trwania                            : 4 min 25 s
Rodzaj przepływności                    : Constant
Przepływność bitów                      : 256 kb/s
Kanały                                  : 2 channels
Channel layout                          : L R
Częstotliwość próbkowania               : 48.0 kHz
Szybkość wyświetlania klatek            : 46.875 FPS (1024 SPF)
Compression_Mode/String                 : Lossy
Rozmiar strumienia                      : 8.10 MiB (1%)
Tytuł                                   : SoundHandle
Język                                   : English
Zdekodowana data                        : UTC 2018-10-13 16:47:08
Znakowana data                          : UTC 2018-10-13 16:47:08


Ustawienia projektu
   

Ustawienia renderingu
   
Odpowiedz
#2
Za każdym razem inny klatkaż (źródło, projekt, render).
Zdecyduj jaki standard zastosować, użyj "disable resample", żeby program nie miksował sąsiednich klatek, renderuj z profilem "HIGH", (zamiast MAIN)
Odpowiedz
#3
Ok to może trochę doprecyzuję. Przed napisaniem tego wątku przeszukałem już trochę forum i próbowałem każdej kolejnej porady, więc zastosowałem już wcześniej opcję disable resample, wyłączyłem GPU, na początku tworzenia nowego projektu skorzystałem z opcji Match Media. Żadnej poprawy nie było. Spróbowałem już renderowanie z profilem High ale to też nic nie dało. Zauważyłem jeszcze pewną rzecz, kiedy wyświetlam oryginalny filmik w odtwarzaczu to płynność jest bez zarzutu, jednak kiedy wrzucam ten filmik do vegasa to już na etapie preview filmik traci na płynności dokładnie od tego samego fragmentu jak po renderingu.

Dodam tylko, że jestem kompletnym amatorem w tym programie a korzystanie z niego ograniczam do połączenia ścieżki wideo z audio i nigdy nie miałem takiego problemu jak teraz. Komputer wydaje się nie być problemem bo ma dobre parametry: Intel Core i7  2.80GHz, 16GB RAM, Intel HD Graphics 630, GeForce GTX 1050Ti.
Odpowiedz
#4
Profil wysoki - to zawsze wyższa jakość. Dlatego powinno się go stosować.

Brak płynności, w Twoim przypadku wynika z tego, że źródło jest nagrane telefonem. Telefony bardzo często nagrywają z zmienną ilością klatek. Odtwarzacz potrafi to pokazać, ale żaden program montażowy nie obsługuje zmiennego klatkażu.
Używając "match media", program uśrednił i ustawił 30.008 fps. Ale to nie ma znaczenia, jeśli nie renderujesz zgodnie z ustawieniami projektu - a Ty renderowałeś 29.97.

Każda niezgodność klatkażu wpływa na płynność.


Najlepiej ustandaryzować jakąś sensowną wartość i użyć disable resample. Ale i tak nie uzyskasz płynności porównywalnej do oryginalnego pliku. Nie ma szans.

Ps. Spróbuj ewentualnie wyższe klatkaże (50fps). Przeskoki powinny być mniej zauważalne.
Odpowiedz
#5
Przy renderingu nie mogę ustawić wyższego klatkażu niż 29.97. Pewnie coś robię źle. Jeśli wiesz co może pomóc w mojej sytuacji to proszę, wytłumacz to troglodycie czyli mi :)
Odpowiedz
#6
Ograniczenie MainConcept.

Spróbuj Sony AVC.
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości