Jak renderować filmiki na YT.
To mój pierwszy post na forum i na pewno nie ostatni ;)

Przy dostosowaniu wszystkich parametrów jak w tym poradniku mam problem z poszarpanymi krawędziami

http://s1.img.pl/v/140215/beztytulu.png

Na materiale wejściowym i podczas podglądu w SV wszystko wygląda dobrze.

Materiał wejściowy to 1980x1080i 25kl/s 16Mb/s i 24Mb/s , sony vegas pro 11 x64
Wyjściowy to identycznie jak w poradniku z tym, że zmieniłem rozdzielczość z 1280x960 na 1980x1080 i "pixel ratio aspect" na 1,3333 (próbowałem też bez zmieniania tego 2 parametru)

Kodeki najnowsze z oficjalnej strony

Pozdrawiam



Edit:

Moze doradzicie jakiś inny sposób konwersji?
Interesuje mnie wgranie na yt oraz wyświetlenie na rzutniku(projektorze) 1280x960 lub 1024xcoś
max. waga pliku 7GB

P.S. Nie mam obecnie dostępu do dobrego sprzętu więc dobrze by było jeżeli kodek nie będzie zbyt wymagający :P
Odpowiedz
1920x1080 powinno być z Pixela Aspect Ratio 1., a nie 1.333
Przeplot zostaw taki, jak w oryginale (jeśli był górny, to zostaw górny, lub usuń zmieniając na proresywny. Jeśli był dolny - zostaw dolny, lub zmień na progresyzny. NIGDY nie zmieniaj górnego na dolny, i odwrotonie!).

Co do kodowania, to polecamy Sony AVC, lub MainConcept AVC z kodowaniem 4-4.5Mbps (YT wszystko co ma większą przepływność, przekodowuje do właśnie takich parametrów - testował ktoś na forum...).
Aby uzyskać lepszą jakość, wybierz MainConcept, oraz dwuprzebieg.
Odpowiedz
dobra dzięki, zaraz przetestuję

Jeszcze mam kilka pytań:

frame rate zostawić na 29,970 czy obniżyć do 25 kl./s ??

bps zostawić 16 000 000 czy można bez znacznego pogorszenia obniżyć? edit: już wiem, obniżyć do 4.000.000 ?

Format pliku zostawić domyślny ( .m2ts ) czy lepszy będzie mp4 lub avc?


Z góry dzięki
Odpowiedz
Framerate - zostaw jak w oryginale - żeby najlepiej wyglądało.

Bitrate... obniżyć do 4-4.2, ale to nie będzie zbyt dobra jakość. Żeby uzyskać lepszą, użyj dwuprzebiegu (tylko MainConcept AVC).

Format pliku? - automatycznie powinien się ustawić na MP4. Ale youtube łyknie chyba wszystkie te formaty.

Najlepiej zrobisz, jak przetestujesz (jakiś mały fragment - choćby 30sekund...).

Na koniec podziel się doświadczeniami. Na pewno jeszcze w tym tygodniu ktoś założy podobny temat ;), więc zostanie dla potomnych.

Z góry dzięki :)
Odpowiedz
Korzystam z SONY AVC, 1920x1080 4Mbps, 29,970kl/s i jest wyśmienicie jednak yt zapisze to jako 480p
Youtube spokojnie "łyknie" .m2ts
Jesli jednak chcemy, aby nasz film przy rozdzielczości 1920x1080 na yt miał opcje wyboru HD 1080p należy przesłać plik stosując się do tabelki na tej stronie:
http://support.google.com/youtube/bin/st...e=guide.cs (na samym dole)

(Jeśli komuś nie chce sie patrzeć to podaje gotowe)

1080p
video: 8000 kb/s = 8mbps
dźwięk mono: 128 kb/s
dźwięk stereo: 384 kb/s
dźwięk 5.1 : 512 kb/s
Odpowiedz
zzrobilem tak jak w tym poradniku i na poczatku mialem kilka razu pod rzad blad, przy renderowaniu i moglem wyslac rapori i nie wysylac, zrobilem screeny z ustawieniami i chcialem juz pisac posta tutaj ale zrenderowalem jeszcze raz i sie udalo, pewnie cos pominalem, jakis maly istotny szczegol.
gotowy film trwajacy 43sek zajmuje 91mb
przerobilem ten sam film w programnie FormatFactory, na kodek MPEG4 Xvid i film zajmuje mi 51mb a jakosc wydaje mi sie bardzo podobna z tym ze kodowanie audio w FF dalem domyslne: 128kb/s
jest to jakas roznica w tym?
stosowalem rendering 16:9
Odpowiedz
A ja zawsze byłem ciekaw, czy kompresja do docelowej jakości YT z lepszej wejściowej będzie wydajniejsza niż z gorszej. A ponieważ nie ma konkluzji co do bitrate, poniżej którego nie widać straty jakości w FullHD, zrobiłem 4 filmy testowe. Każdy z nich:
- ma inny bitrate
- każdy ma ten sam tytuł (żebyście się nimi nie sugerowali)
- każdy zawiera ten sam fragment wideo (kamera się trzęsie, bo chciałem, żeby to było ciężkie dla Vegasa).

Miałbym do Was prośbę. Nie powiem Wam, który film jest który, a Wy - jeśli możecie pomóc, macie monitor FullHD i dość szybki net:
- poświęćcie 2 minuty na obejrzenie tych filmików
- spróbujcie ustawić te filmy od najlepszej do najgorszej, bo chciałbym wiedzieć, czy widzicie różnicę w jakości, a upload w 12-17MB/s w ogóle ma sens.

FILMY:





Będę wdzięczny za pomoc.
Pozdrawiam,
Skrzyp
Odpowiedz
Słuchajcie, mam problem.
Mam materiał ze starszej kamery cyfrowej, nagrywa z przelotem.
Wg mnie ustawiłem wszystko tak jak należy w ustawieniach projektu.
Ale po renderingu widzę nieustannie lekkiego "duszka". I nie wiem czemu. Nie mam pomysłu co mogę zmienić by się go pozbyć bo wg mnie wszystko zostało poprawnie ustawione gdyż bazowałem na automatyce.
Automatyczne ustawienie projektu po wskazaniu na dany klip, do tego rendering z presetu któremu towarzyszył znaczek "=". A nie działa.

Klip wejściowy to:

Kod:
General   .MOD
Format            : MPEG-PS at 9 285 Kbps
Length            : 143 MiB for 2mn 9s 568ms

Video #0          : MPEG Video at 8 900 Kbps
Aspect            : 720 x 576 (1.778) at 25.000 fps

Audio #0          : AC-3 at 384 Kbps
Infos             : 2 channels, 48.0 KHz


Problemem nie jest przeplot, tylko taki jakby "duszek".

[Obrazek: attachment.php?aid=613]


Załączone pliki Miniatury
   
[Obrazek: n13.gif]
Odpowiedz
Bunch, po tak długim czasie na forum powinieneś chyba widzieć, że wróżkami nie jesteśmy do k... nędzy. Podaj ustawienia projektu i renderingu. Wrrrr...

@Skrzypiec - najgorsza jest wersja 1, potem czwarty, następnie trzeci. Drugi jest najlepszy wg mnie.

Maciej Lewandowski - efix.pl
Odpowiedz
Przepraszam. Ale myślałem, że to wystarczające informacje.

Oto ustawienia:

[Obrazek: przepra.jpg]

I co ciekawe, obraz (podgląd) w Vegasie (i nie tylko w sumie, w odtwarzaczu systemowym również) jest "ściaśniony". Tak jakby 16:9 do 4:3 zwężyło się. Więc eksperymentuję i z presetu jaki odczytało 1,0926 (PAL DV) zmieniam na: 1,4568 (PAL DV Widescreen) - wtedy podgląd się rozszerza, zostawiając czarne paski po bokach. No to widząc to, uciekam do opcji klipu i w jego opcjach zmieniam też aspekt piksela na 1,4568 (PAL DV Widescreen). Działa! Obraz zrobił się w końcu poprawny. W sumie to dziwne dlaczego Windows widzi go niepoprawnie i sam Vegas zresztą też.

I co dalej idąc mnie zaskakuje to to, że wciaż jest widoczny przeplot. A prócz niego widoczny jest "duszek". Oczywiście w klipie zdefiniowany jest taki sam przelot (dół lub góra) jak w projekcie - co oczywiste.
Szybko możecie to zobaczyć, spoglądając na fioletową kurtkę, z niej tworzy się charakterystyczny duszek.

[Obrazek: przeploits.jpg]

Więc reasumując... Mimo poprawnego ustawienia projektu (przez sam program, a nie przez moje "widzi mi się"), projekt wciąż nie wyświetla prawidłowo obrazu. Po renderingu, jak i w podglądzie widać przeplot + ducha.
[Obrazek: n13.gif]
Odpowiedz



   


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości